QualiMap Multi-Sample BamQC does not load in center panel

The QualiMap Multi-Sample BamQC wrapper in usegalaxy.eu does not work, showing a pink-colored flagged error message: “Uncaught exception in exposed API method:”

1 Like

Dear @Mario_Garcia,
The tool should work, I tested it right now with some test data. Please make sure:

(a) your data was correctly analyzed by QualiMap BAM QC (i.e., the files should not be empty),
(b) your files come from the same organism and data library
(c) and you data has no weird characters in their file name.

If the error still exists, then please make an error report (click on the bug-icon and send an error report, see here: Issue Reporting), so we can see the standard error and standard output of the job. You can also share your history here or with me via message (see also Issue Reporting for sharing your history).

Have a good day and best wishes,

Dear Florian,
Thank you for your prompt reply. There is nothing to check in my data because I said, the usegalaxy.eu wrapper for Qualimap Multi-sample BamQC does not run. Clicking on it just shows the error message I have described in my first post.

I saw an error report regarding this tool I think from you today. Seems you manage to run it, but got a different error this time?

1 Like

Dear Florian. The former error still remains.

1 Like


I just tried loading all of these tools from the tool panel at usegalaxy.eu and each loaded correctly/successfully.

Try refreshing your browser window, then loading the tool again. The server is quite busy right now, and the loading failure was likely transitory – refreshing your connection to the server might be needed.

Dear jennaj,
Thank you for your reply. I have just reloaded two different browsers and re-logged my user account but the same error still remains.

1 Like

Very odd. Maybe try clearing the browser cache? Or a different browser? Plus, make sure cookies are enabled. This doesn’t look like a server-side issue since no one else can reproduce it (?) – or at least three other people cannot: one in the EU (@Flow), one in the USA (me), and another person working at this server during the GCC2021 training going on right now (not sure from where!).

I’m not sure how I can help more – but the EU group will be back online in their morning :sunrise_over_mountains:

I almost suspect, that this has something todo, with the data you have seleced. Can you share your history? Either with me directly via message or via link here in this post (but make sure you allow the data to be assessed). It would be of interest for us to check if there is a bug in the wrapper.


1 Like

Dear Florian,
Thank you for your reply. As I’ve explained before, I do not select any data, just click on the tool at the left tools panel and the error window is showed.

Hi all,
I verified the issue. It happens only in the Mario’s account.
Really odd.
I check the logs, hoping to find some explanation.

@Mario_Garcia You have fallen into a bug.

As you can verify, the first steps of your history don’t have a number, but null.
How did you produce those steps? Will be really useful to fix the bug if you can provide some details (in the issue page better).
Did you get there by clicking on re-run on an element of a mapped over collection ? This is an action we know to create this issue.

As a temporary workaround, I can suggest creating a new history, move the needed datasets there and run the tool.


Dear gnauro,
Thank you for your clues. I’m not sure about how those null jobs has been created. I only remember to have run on some elements from browsing the datasets (the open folder icon at right of input data fields). In fact, clicking on that icon the same error happens: “Uncaught exception in exposed API method:”
I will try your suggested workaround. Thanks.

Your workaround works and the error is fixed. Is it a coding bug?
Thanks a lot all people for help and support.