Removing spliced alignment from BAM after Hisat2

Hello everyone,
I am analyzing 12 mixed samples containing 4 different species: 1 eukaryote and 3 prokaryotes. In order to remove the multi mapped sequences, I mapped my samples to the reference Hologenome that contains the genomes of all the 4 species. For the mapping, I used Hisat2 with standard settings.
Here is the problem: the eukaryote has splicing while the prokaryotes no. I ran Hisat2 aligning also the spliced reads (Spliced alignment options >> Disable spliced alignment >> False). How Can I remove the spliced alignment from my prokaryotes BAM files? Is there any filtering option?

The only alternative I found is to align the samples 2 times, once with the splicing option activated and the second time without the spiced reads. In this way, I would use the first one for the eukaryote and the second one for the prokaryotes. However, I am not sure this option would be correct.

Thank you

1 Like

Welcome, @Dave_P!

Is the data RNA or DNA? What is your analysis goal?

Hi Jenna,

My data are RNA, SE stranded. I need to analyze the differential gene expression between 2 treatments, in all the 4 species. I also have all the different genomes separated and I can run them separated but I wouldn’t know how to remove all the genes mapped to multi-species.

Thank you