setting up as administrator

galaxy-local
become-an-admin
#1

I am running a VirtualBox Ubuntu 18.04 on Windows 10 and got all the way through installing Galaxy fine, but am having trouble getting administrative privileges. As instructed, I opened up the galaxy.yml.sample file, added the line

admin_users: myname@gmail.com

at the very top and started up Galaxy again. I logged in and set up a password but could see no evidence of an administrative tab anywhere on the task bar or the pull down menus. Where would it be?

I also tried it as:
admin_users: ‘myname@gmail.com’
with no difference.

In looking at the output of the sh run.sh file in the terminal mode at the point where I have to start up the browser two error messages consistently show up:

Starting server in PID 3636.
serving on http://127.0.0.1:8080
/home/paul/galaxy/.venv/local/lib/python2.7/site-packages/sqlalchemy/sql/sqltypes.py:603: SAWarning: Dialect sqlite+pysqlite does not support Decimal objects natively, and SQLAlchemy must convert from floating point - rounding errors and other issues may occur. Please consider storing Decimal numbers as strings or integers on this platform for lossless storage.


uwsgi-fileserve] security error: /home/paul/galaxy/static/scripts/bundled/base.css is not under /home/paul/galaxy/static/style/blue or a safe path

Does do these indicate anything about what is going wrong?

PAS

1 Like
#2

Hello,

The idea is not to add in a new line but to edit the existing parameter. Remove the starting hash “#” and replace the default value with your own admin email address.

FAQ: https://galaxyproject.org/admin/get-galaxy/#become-an-admin

Thanks!

#3

Please follow the instructions here and create galaxy.yml https://galaxyproject.org/admin/get-galaxy/#configure. Do not use the sample.

Also note the config file has structure, do not add the settings to the top but to the appropriate section.