SyntaxError: invalid syntax


I am having trouble with the startup of galaxy and was wondering if someone can help with this? I was able to downloaded galaxy and tried running it, however, I am getting this message:

I have python 3.8 downloaded and followed the following instructions on letting Galaxy know which python to use: Supported Python versions — Galaxy Project 21.09.dev0 documentation

Thank you again for your help ahead of time!

Hi @Xiong,
could you provide us with more information about the commands that you used in order to run Galaxy?


My command is “sh”

I was able to successfully set python3 as my default and was able to run Galaxy.
I am now attempting to login via local galaxy, however, I am unable to and Galaxy says “No such user or invalid password.”

I had indicated my email via the galaxy.yml in config

Thank you.

I had indicated my email via the galaxy.yml in config

@Xiong I assume you mean you added your email to admin_users?
After doing so you still need to register to activate that account and provide a password for it.
All the admin_users setting does is make sure that after regsitration your account is treated as an Admin account.