Upload error on local galaxy

When I try and upload to my new local install of galaxy I am getting the following error below:

I have tried changing the file_path in galaxy.yml or # hash it back out to default. No real change in the error code and it always errors.

“(sqlite3.OperationalError) near “FROM”: syntax error
[SQL:
UPDATE history_dataset_association
SET
info = ?,
update_time = ?
FROM dataset
WHERE
history_dataset”

Welcome, @prm123342 !

These are our resources. I would suggested walking through the configuration tutorials first to find what may have been missed.

Once you get oriented, you can ask more question within that context and more people will be able to help :slight_smile:

Same problem. What to do next?

Thanks, I re-did everything from an earlier version 20.9 and that seems to have worked. Not sure what step exactly was wrong.

Please kindly let me know what the “everything from an earlier version 20.9” means, thank you in advance.

I’ve tried v20.9, with errors as following:
➜ galaxy sh run.sh
Creating Python virtual environment for Galaxy: .venv
using Python: python3
To avoid this, use the --no-create-venv flag or set $GALAXY_VIRTUAL_ENV to an
existing environment before starting Galaxy.
Fetching https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-16.7.9.tar.gz
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
100 5001k 100 5001k 0 0 1649k 0 0:00:03 0:00:03 --:–:-- 1757k
Verifying /tmp/galaxy-virtualenv-v3kiQj/virtualenv-16.7.9.tar.gz checksum is 0d62c70883c0342d59c11d0ddac0d954d0431321a41ab20851facf2b222598f3
Using base prefix ‘/usr’
New python executable in /home/zhang/galaxy/.venv/bin/python3
Also creating executable in /home/zhang/galaxy/.venv/bin/python
Installing setuptools, pip, wheel…
done.
Activating virtualenv at .venv
/home/zhang/galaxy/.venv/bin/python: Error while finding module specification for ‘pip’ (AttributeError: module ‘main’ has no attribute ‘file’)

1 Like

Sorry to hear about you upload error. But sometimes due to network issue it shows this error even i faced this issue sometimes.
Or sometimes due to glitch either.
check your network once, maybe this is the thing which is making an error.