Trinity job waiting to run for 48 hrs

Hello. I have tried to run Trinity for a de novo transcriptome assembly of RNA-Seq data that has been trimmed successfully using Trimmomatic but the job is still waiting to run. I have executed Trinity operation 48 hrs back but it is still grayed out. The job didn’t start yet. Please help me out with the issue. I am eagerly waiting for the Trinity successful results.

1 Like

Welcome, @Sutrisha_Kundu

The jobs sound like they are queued. Leaving everything just as it is will be the fastest way to process the jobs. Next time, consider setting a notification when submitting the job :slight_smile:

How jobs process at public servers →

At, you can also check on currently queued jobs by reviewing the Server Statistics. Find those linked from the server homepage →

As of right now, it looks like there are 125 Trinity jobs queued. Yours are in that batch, so be sure not to lose your place! Instead, allow the current jobs to move through the queue and process. :slight_smile:

Hope that helps!

The trinity job is still grayed out. It has been 4 days now. Can you please help me out whether it will run successfully or not. I have been waiting for 4 days for it to just start running.
Thank you

Hi @Sutrisha_Kundu

Right now there are over 100 Trinity jobs queued, so the server is working through a batch of assembly jobs related to that tool.

I can’t check individual jobs at the EU server but you can reach the EU server administrators directly at their chat. Find the link at the very bottom of that same server homepage. They will want your username (not your email address) – find that under User → Preferences in your account if you are not sure what you used.

Be sure to leave that job queued until you get feedback, or it processes by itself.

I am really worried now because the trinity jobs are still grayed out. It has been over 8 days but still the jobs haven’t even turned yellow. They are still waiting to run. Please help me out. Please please. I have also tried to find the chat at the bottom of EU server homepage but I couldn’t figure out the link for chat. I found a mail id, where I have mailed regarding this issue but no response yet. Please help me. I am really in need of the Trinity results now.

hi, @Sutrisha_Kundu
Based on my previous experience, the tasks you submitted could not be executed by Galaxy in the following two situations. The first scenario is that the disk space you are using has exceeded the system’s allocated space (each account is only allocated 250G for Galaxy EU, and once the data occupied space exceeds this size, all commands will be paused indefinitely. The second scenario is that the task you submit requires too much system memory, which often occurs for the Trinity on Galaxy USA and Galaxy EU servers. For paired-end illumina data, the amount of data you submitted for one analysis by Trinity should not exceed 6 samples (12 files). Good luck!

weidong lu

1 Like

I have just used 41% of the disk space, only 103 Gb has been used till now out of 250 Gb. Secondly, i have uploaded just 2 files (1 sample only). Still, the trinity is not running.

I just entered my Galaxy USA account and tried to assemble a sample (2 files) with Trinity. After submitting the task, the colour of the panel changed from gray to yellow in just about 5 -10 minutes (it started running). You might have a try, maybe the Galaxy EU server has too many tasks and needs to queue up.


Hi @luweidong and @Sutrisha_Kundu

Everyone could use rnaSPAdes instead!

We are getting ready to deprecate all Trinity tools at due to age and inefficiency in how the tools work. Note that the Trinity tools will still be available, but will not be supported after today.

Also, only one Trinity assembly will run at a time at, so plan for those delays. rnaSPAdes will run as usual with concurrent job processing.. How other public servers run these tools is not part of this particular resource adjustment.

Galaxy Training Network ← search with the keyword “quality” to find help for QA. Assembly is very sensitive to read quality and should never be skipped.

Transcriptomics / Tutorial List ← see the Intro tutorials here, and the end-to-end trio, for alternatives if the goal is to do RNA-seq DE analysis. Actual assembly is not needed unless you plan to do variant calling or something similar…

FAQ: Extended Help for Differential Expression Analysis Tools ← tips for preparing your reference data

Galaxy Help forum << legacy troubleshooting help is here about this tool, so try a search with the tool name

Running pooled samples is unlikely to work well at If this is what you really need to do, try at since they can scale up the largest for this tool. Plan for the time needed to queue and execute, and let the jobs complete. Or, you could explore private options like AnVIL - Galaxy Community Hub

Hi @jennaj
Thank you for your kind guidance.

Ok thanks a lot for your constant support and guidance.

The galaxy europe was under maintenance for the past two days. Is it working fine today? The jobs are still grayed out. So, I am asking.

Hi @Sutrisha_Kundu

That same message states that job may stay queued for a few days longer after completed. And, the message was updated to state the maintainance is still happening today (April 10th).

What this means:

  1. The actual maintenance part is still happening right now.
  2. It was expected originally that there would be a backlog of work to complete after everything was back up and running.
  3. So, the administrative tasks are still happening, and the job processing after seems to be what will happen.
  4. If any part of that changes, I would expect that message on the server to update to reflect anything the administrators can share about the process.

Screenshot of server message from today, April 10th 2024

Screenshot of where to check what is actually processing once everything is back up and running as usual

Hope that helps! I’m going to mark this topic as completed since there isn’t anything extra for us to explain here. The resources above are what to check.

Thank you.

I had started few jobs last tuesday. I had run diamond, trinotate, transdecoder, busco, etc. jobs but none of them have even started running after maintenance. All the jobs are grayed out. None of the jobs have run nor produced nay results. I have tried to reach your support through mail, but nowhere did I get any reply. Also, when i try to see the Galaxy Europe statistics, it doesn’t show up and only a message shows that it took too long to respond. I am unable to work further in Galaxy europe. All my jobs are stuck in grey colour.
Could you please help me out and resolve the matter. Please please please.