Visualization of box plot(jqPlot) problem

Hi Galaxy team!

I started training on Label-free data analysis using MaxQuant.
I have a problem with “Visualize this data” on the cut tool result.
When I selected box plot(jqPlot) it did not visualize data.
Instead a message “Please confirm the settings before rendering the results” appeared.

With best regards,


Hi @Arman_Kulyyassov,
thank you for your report; I contacted the person in charge of this training in order to check the problem.


Hi Arman,
the Galaxy interface has changed a bit. When you see the message “Please confirm the settings before rendering the results” you should see two small arrows on the upper right corner of the screen. Once you click on them the menu appears which allows you to set the specified parameters.


1 Like

Dear Melanie,

thank you very much for your letter and helpful advice. I followed instructions but instead of a visualization plot I get this:

Hello Arman,

I’m facing the same issue now. I tried 3 different browsers, but it’s not working.

How did you do to visualize the boxplot?

Best regards,

Raquel Neres

Welcome, @Raquel_Neres

Look under User → Visualizations

The data will take variable time to render … and the “Please wait…” message will appear on the left side of the window. Let that complete to see the graphic.

Which web browser you are using shouldn’t matter too much since the data is server side. Safari, Chrome, and Firefox are good choices. Avoid Internet Explorer. Make sure cookies are allowed (that is how Galaxy “knows” that you are accessing your own data, so privacy reasons).

Reference: Label-free data analysis using MaxQuant

The GTN is hosting a training session all next week. Everyone is welcome to join to interact with the authors and trainers. It is fine to still register. Smörgåsbord 3: A week of Free, Online, Galaxy Training supported by the Global Galaxy Training Community

I’m still having this issue after following your advices (with a different training).

So I created a visualization using Box Plot (jqPlot) and it is then listed under User → Visualizations. However, when I click the visualization, the following two messages are displayed subsequently:

Your job has been queued. You may close the browser window. The job will run in the background.

and then:

Your job is running in the background and you may close the browser tab. Results will be available in your saved visualizations list.

When the second message vanishes, the window remains empty. No visualization is shown:

There are also three data series configured.

I also noticed that in the History pane, the visualization item is generated as of “format tabular”, which seems wrong to me?

Hi @kostrykin

The server had some problems that were just resolved. This is what probably caused your delays as well: Cluster issue at -- Resolved 06/05/2023. Rerun failed (red) or leave queued (gray) - #3 by jennaj

This tool will generate a tabular output to hold the visualization information (what is specified on those details screens where you are specifying how to plot the data). Then, when the visualization is viewed, that table is parsed into a graphic, on demand. You might need to do that “generate graphic artifact” process over again – or maybe that part was completed and the graphic will render now.

Let us know how that goes, and we can follow up. If you want to share a history link back for outstanding issues, we can take a look to make sure more is not going on. Sharing your History

Hi @jennaj thanks four your quick response, however, the problem still persists, as described above, I only get a blank screen when using the “Box Plot (jqPlot)” visualization tool (I’m using the server).

Here is the link to my history: Galaxy | Europe
I’m trying to produce a visualization of 219, while following this tutorial: Analyse HeLa fluorescence siRNA screen

1 Like

Ok, thanks for clarifying. I’m looking now…

Hi @kostrykin

The how-to for the job seems to loop, and never produces a graphic. It cannot even be downloaded. I tried modifying the chart metadata to make the naming “unique” but that was not enough.

This seemed specific to certain chart types, and I found an issue ticket. The correction will be available at the UseGalaxy.* servers after the next release. No … sorry, that was a different chart type. I opened up a new issue, and used your example from the tutorial (copied over to the server to make sure not server-specific problem).

I’m not sure of an exact workaround … but the tabular file is an appropriate input. There is likely a way to use the application directly as an alternative for the graphing portion.

Apologies for missing this earlier!!

Thanks for your efforts and the bug report! I subscribed to the issue.

1 Like