BAM files error with Salmon quant

I’m trying to process paired end RNAseq data and I would like to use the deep tool PlotCorrelation to compare datasets.
The RNAseq raw data has been downloaded from the service provider server and then uploaded on galaxy (fq.gz files). I did a fastQC on it, then I used Trimmomatic to remove adapter and Cutadapt to remove read < 20pb. After those steps, I ran FastQC on every datasets and visualized report with multiQC (so far it seems to be ok).
Then, I tried to use Salmon quant to quantify the reads. To do so, I downloaded the Wheat transcriptome from Plant Ensembl, upload it in galaxy (gq.qz file) and run Salmon quant (I ask the program to wright BAM files in output). The output quantification files seems to be OK (I can open it and it looks like what I expect). The problem is that I would like to use the produced BAM files in mutliBAMSummary in order to use Plotcorrelation, but I’m not able to produce BAM files without an error message : “An error occurred setting the metadata for this dataset [Set it manually or retry auto-detection]”. Those files dos not work as input in MultiBamSummary and I can’t open or visualize it (the BAM file seems to respond like in this post : How to upload locally built reference genome to galaxy cloud server.

Help will be very appreciated.


I tryed HiSAT2 instead of Salmon quant, but I got the same issue with the BAM files … I see that some people had similar problem in the past : HISAT2 error: Auto-detection

I tried the auto-detect function as advised in this post. A little green box with "XXXX"appear but nothing has changed with the BAM file : BAM file is 3.2GB, can’t visualize it and doesn’t work as input for ValidateSamFile or Samtool sort. I’m digging the FAQ, but any advice will help.