bedtools doesn't work since Maintenance

I use the tool “bedtools Convert from BAM to FastQ” in my workflow, and since the maintenance this April, I have not been able to run my workflow properly because of it. I even tried with data that I used before and now I don’t get the expected results. Every time that I try to convert my BAM file to FastQ using this, I will get a FastQ file with less than 5 sequences. When I tried by myself in my terminal with the same data with other tools such as “samtools bam2fq”, it gave me around 20k reads for the same file. Is there any alternative in Galaxy to convert from bam to fastq? O can someone check why this tool doesn’t work anymore?

Hi @vcruz

Super odd behavior.

If you rerun that tool outside of the workflow but still in Galaxy (use the rerun icon for the original output) do you get the same result?

And, have you opened that workflow in the editor to check for warnings about tool updates?

Let us know about those items please. A workflow should produce reproducible results, or have some notice about changes: either at runtime at the top of the submission form or within the editor itself.

If you could also confirm that this is happening at (sounds like so just double checking :slight_smile: ) that would be great.

Sharing your workflow is also a possibility. You can do that here.

Or, you could just share the history with that odd output, and let us know what dataset to look at. I wondering if something is going wrong with the parameters or the interpretation of the BAM file.

We can sort this out! :hammer_and_wrench: