Bracken troubleshooting

Hi everyone, i asked about Bracken not working a few months ago. Apparently it was fixed but i am still getting an error. Here is what my data looks like. What am I doing wrong? I have the Kraken data which is what i need?

Kind regards

Hi @Martyn

I don’t see an error in your screenshot? You can share more details if you want more help.

I also started up a quick test run using the tool test data – get that test data loaded into a history using the Options → Generate tour function (ignore any warnings, let the data load, then start up a test job). The test was successful.

Hi Jennaj, Here is the screen after i ran the data analysis.

I hope this helps?

Best wishes

Hi @Martyn

That helps, thanks!

The last line of the error message is about the tool finding the wrong sort of character type in the input. Commonly that is due to one of these:

  1. a compression format that either was or wasn’t found but expected. For this – check that the assigned datatype of the input is correct. If you Uploaded that input, that is where a mismatch could be introduced.

  2. a different “value” then was expected in some column of the file. It was looking for a number. something as simple as an extra space inside a value in the file can lead to this.

So, my followup questions are…

  • what is the metadata label on the input file (datatype aka “format” in the expanded dataset in the history)
  • does that change if you re-detect the datatype again (pencil icon) or if you Upload the file again and let Galaxy guess, and
  • what does the actual file content look like (eye icon)?

Note: in your first screenshot, the first question is sort of answered – tabular and taxonomy are the labels, but the collection currently selected in that screenshot is the wrong input – the input is for the “Report” output from Kraken, but you have the “Classification” collection selected. That mixup could lead to the error you got if that is what was submitted.

If you aren’t sure which was submitted to that error job, click in the “i” icon instead of the “bug” icon to review the full input/parameter logs plus the other two logs from the error job.

The way that the data is labeled suggests that a third collection from the original screenshot was input – a collection created from one of the others, converted to a new datatype? That won’t work. Try using the “Report” collection instead as an input.

Try switching to use the input collection of the “Report” files in the original tabular format since that seems like it will be enough. If not, you can post more screenshots of the things mentioned above.

Hi JennaJ. Thanks again for getting back to me. Here are some screenshots.

I changed to the Kraken report file here which is in a tabular format

Here is what the kraken report tabular file look like when i click on the eye.

Here is the error report from after running Bracken

I hope this is enough? I am not sure what else to do.

Best wishes

Hi @Martyn

Yes, thanks for sharing the details.

The tool doesn’t want to use inputs in the current format. So, you’ll need to change up what you have, or choose different options with the upstream tool (Kraken2).

What to do:

  1. Review the tutorials for example data.
  2. Review the test history example data.
  3. Review the Kraken/Kraken2 tools in the tool panel. Each has a help section with link outs to the first item in this list, plus more resources from the authors.

Example tutorial step: Hands-on: Hands-on: M. tuberculosis Variant Analysis / Variant Analysis

And another with a similar step, plus a screenshot of what the output looks like (is the same as in the tool test): Hands-on: Hands-on: Taxonomic Profiling and Visualization of Metagenomic Data / Microbiome

Screenshot of the reporting options on the tool form. I’m pretty sure that you want the first Print a report with aggregate counts/clade to file for the “report”. The second choice is definitely incorrect given your error message – Meaning, Braken was complaining about the “mpa” format.

Hope that helps!

Thank you jennaj, that has worked and its helped me out a lot… Thank you.

I am still learning :slight_smile:

1 Like