Cant purge a data set due to immutable data

I’ve tried to purge a dataset, but it keeps telling me the dataset is immutable. I think the issue is all the hidden files, but I can’t unhide them or delete them, they’re just stuck.

Are you sure it is not purged already? Because you’d see that error trying to operate on a purged dataset.

It is already purged but it is still taking up data in my storage. Also, when I go to it in my deleted histories it shows its been purged but is still taking up space.

Hi @Seb_B

After purging data, the server will catch up in a few days, or you can force the recalculation to happen quicker by using this function:

User → Preferences → Storage Dashboard, then use the Refresh function. Let that fully complete to see the newly recalculated quota usage.

Hi I tried this and its still there.

Ok, then …

  1. Go into User → Histories
  2. Click into Advanced Search
  3. Toggle history status == all

That will show all of the data in your account that is still counting toward quota usage, summarized by history. Maybe you need to purge more data?

Hi, I’ve done this. The data says its been permanently deleted, however It is still being counted towards my storage.

Hi @Seb_B

Did you solve the problem?

If not, where you are working might be a factor. What was described above are the general data management steps for end users working at public Galaxy servers.

Public servers should also have direct, private, administrative contact information somewhere on the homepage. That information would also be in the original registration email (the one with the link). You can also check in this directory (same place we would look for it) → Galaxy Platform Directory: Servers, Clouds, and Deployable Resources - Galaxy Community Hub

If you are working at a private server, and are not the admin, try contacting whoever is the admin. If you are the admin, the server might need some more configuration “tuning” to fully purge old artifacts.

Let us know if you need more help. The URL of the public server please, at a minimum.