Data import LEfSe error: Cannot count lines in file

Hi. I have been using LEfSe in the past and was successfully able to run the full pipeline with the Galaxy LEfSe tool. Now when I am trying to run the pipeline using new tabular files (I believe to be formatted correctly) and even old ones that successfully worked in the past I run into two errors:

Step A) Info to count lines in file /export/galaxy-central/database/files/004/dataset_4265.dat

Step B) Error message:
Number of significantly discriminative features: 36 ( 36 ) before internal wilcoxon
Traceback (most recent call last):
File “/galaxy_venv/bin/”, line 33, in
sys.exit(load_entry_point(‘lefse==1.1.2’, ‘console_scripts’, 'lefse_ru

I have tried to resolve these problems many different ways, but find myself very stuck. If anyone has any reconditions. It is greatly appreciated.

Hello @garretta

Please try again from the start (Upload?).

The server has some issues over the weekend. That likely impacted your analysis. Please see here for details: Cluster issue at -- Resolved 06/05/2023. Rerun failed (red) or leave queued (gray) - #3 by jennaj

Your first error message “Info” indicates that the server couldn’t “read” the input, and I’m guessing that the file is not actually empty. That’s why I am suggesting to reload the data again. :slight_smile:

Please give that a try and we can follow up more if needed. A shared history link or screenshots with more details would be helpful: Troubleshooting errors && What information should I include when reporting a problem?

Hi @jennaj Thank you for the quick answer: I tried starting from the upload step again and run into the same errors. Here is a screenshot of the issues. Getting the data is green (that step did not fail).

Are you working at

I am using:

I am not sure what the difference between the two are. I am more familiar with the format of

Hi @garretta

Ok – thanks for clarifying. You can work at any server you want to but if there is a server issue going on, only the administrators of the server can help with that.

Others have reported problems with that other public server over the last few days, and those admins do not track this forum. They do have contact information in an email address, and run a local forum (or did, so please double check my advice).

Click into this other topic for more details about what is known:

Thank you for the help. I will look into the other forums!

Hi, @jennaj , I have the same error when I run new date into the pipeline, using, for know where is the problem, I tried the date which was successfully able to run, but now it shows this error too. I don’t understand. I report this error, for any possible help. Greatly appreciated and thanks a lot.
The ERROR is:
Number of significantly discriminative features: 396 ( 396 ) before internal wilcoxon
Traceback (most recent call last):
File “/galaxy_venv/bin/”, line 33, in
sys.exit(load_entry_point(‘lefse==1.1.2’, ‘console_scripts’, 'lefse_

1 Like

Welcome, @Xueqian_Yin

When working at that server, you should use the resources they host to ask questions, especially for errors that seem to be server side.

I just checked again and they do have a dedicated forum. The link is on the server’s homepage. I needed to copy and paste it into a new browser window to get the connection correct. Maybe try that way too? Or, just go here:

1 Like

Thanks a lot @jennaj !

1 Like

Update: Looks like they are working on it, and suggest alternative tools too. Leaving this link here for anyone who happens to run into the same issue. LEfSe issues and errors - #5 by Kelsey_Thompson - LEfSe - The bioBakery help forum

i am working on lefse – The Huttenhower Lab (

it used to work very well, but now it doesn’t