Empty list in sub.sample due to error in make.shared

Hi Galaxy Team,

We are doing 16S rRNA analysis of Illumina sequences. For this purpose, we are following a galaxy tutorial (https://galaxyproject.github.io/training-material/topics/metagenomics/tutorials/mothur-miseq-sop/tutorial.html) in which you have to use the Mothur function sub.sample that takes make.shared as input. We have used the same workflow for other samples, in which it worked perfectly fine. However, in this case the sub.sample function doesn’t work and reports an empty list. Furthermore, dist.shared, which also takes make.shared as an input also results in an error.

We suspect the error might be found in the make.shared function, since the output looks weird compared to the other times we’ve ran it. In some way it looks like the OTU numbers are too long, which causes the columns to not align. We have attached pictures of how the make.shared output normally look and how it looks when the columns do not align.

Is it possible that make.shared could be causing our errors or do you have any other suggestions?

We have tried backtracking our steps, and there doesn’t seem to be any mistakes that we can find.


Caroline and Esther