Error executing tool: formatting problem with BED dataset

I am currently trying to upload bed files in order to use the deepTools computeMatrix tool. The bed files appear to be loaded in correctly, but whenever I run the computeMatrix tool I get the below error.

The server could not complete the request. Please contact the Galaxy Team if this error persists. Error executing tool: objectstore, _call_method failed: get_filename on Dataset(id=29454816), kwargs: {}

After the error occurs, the upload bed file job appears red and gives an error that my input file has chrX, but the genome file does not. I am using mm10 when I upload the bed files.

Another person in the lab has used the exact same files and it has worked for them, so any help would be appreciated.

1 Like

Hi - If the same data/tool worked for someone else on the same server, this was likely a transient server problem. This doesn’t look like a partial data upload problem.

Please try uploading the dataset again new, then rerun tools against it. Make sure the upload is complete and that the exact database mm10 is assigned to the dataset once in the history. There are a few mm10 variants that are named in a similar way, so this is worth confirming.

If you get another failure, please send in a bug report by clicking on the bug icon in one of the red datasets. Include a link to this Galaxy Help post in the comments. Be sure to leave all inputs and outputs (even if some are hidden) in an undeleted state. FAQ:

I’m not sure what this means, but mm10 is indexed natively to Galaxy, so this probably isn’t a custom genome fasta file. If it is for some reason, you can skip using it and instead use the native index at with all (or, most) tools, including this one.



The bug report sent in revealed that the BED dataset contained extra spaces. Problematic formatting can produce many types of tool errors, but the solution is the same – fix the formatting, then rerun tools.

Tabular datasets (including BED data) can be cleaned-up a few ways.

1. Fix the dataset formatting locally on your computer, then Upload it to Galaxy after. Do this if you plan to use the data outside of Galaxy as well. Or, fix the data in Galaxy with one of the methods below and download a copy of the format-corrected BED dataset.

2. Remove the extra spaces during Upload to Galaxy. How-to: In the Upload tool, click on the “gear” icon and check the box to “Convert spaces to tabs”. The tool merges all consecutive “whitespace” (actual spaces or tabs) into a single “tab” – which is what is wanted for proper tabular dataset formatting, including BED data. The screenshot below shows where to find the option.

Note: If you ever decide to “paste” (or type in) tabular data lines with the Upload tool, this is a good option to use to avoid formatting issues.

Warning: Use this option carefully. Example: if a dataset has header lines, converting “whitespace to tabs” will be applied to those header lines, not just the data lines. That is not always desirable as it can introduce another formatting problem.

3. Run the tool Text Manipulation > Convert delimiters to TAB on an already loaded dataset. Use the settings shown in the screenshot below. Once the job completes, the result will have the datatype “tabular” assigned. Click on the pencil icon (Edit Attributes) for the dataset to change it back to BED, and save.


General error help: Troubleshooting resources for errors or unexpected results

Support links: