Error running trimmomatic, hisat2 and deseq2

I am following the workflow on RNA-seq data analyses in galaxy but I have been having some challenges. I ran trimmomatic on my fastq files but it always return an error, even when the files did not give any error when I ran fastqc on them. I went further to align them to the human genome using hisat2 and it came out well, but when I ran the differential analyses with DESeq2, I encountered same error, please what could be the problem and how can I resolve this? Thank you.

I don’t know if I can help but also others will not be able to help because your question is missing the error. Can you share which error you get exactly?


Please see the error message I received after running it. Thank you.

Stderr: Trimmomatic did not finish successfully
Picked up _JAVA_OPTIONS: -Xmx28g -Xms256m
TrimmomaticSE: Started with arguments:
 -threads 8 fastq_in.fastqsanger.gz fastq_out.fastqsanger.gz ILLUMINACLIP:/usr/local/share/trimmomatic-0.38-1/adapters/TruSeq3-PE.fa:2:30:10 SLIDINGWINDOW:4:20
ILLUMINACLIP: Using 1 prefix pairs, 0 forward/reverse sequences, 0 forward only sequences, 0 reverse only sequences
Error: Unable to detect quality encoding

Not sure if you can do anything about it now. I came across this one Trimmomatic Error: Unable to detect quality encoding and I don’t see the option to choose the phred encoding. There is already an github isseu Trimmomatic error: unable identify Phred quality encoding · Issue #79 · fls-bioinformatics-core/galaxy-tools · GitHub. I think for now you could maybe try to use another tool like cutadapt or Trim Galore. (Trim galore uses cutadapt in the background but it has an “automatic detection feature”)

1 Like

Thank you. I will try the suggested tools.

Hi, please I am also having a space issue, although I have sent a mail requesting for additional quota because the jobs that I am running now have paused.

Although, I have purged earlier data and results but still having this issue. While I await further response to request, is there anyway I can navigate this? Thank you.


I don’t think your message will reach the admins, the title of your topic is “Error running trimmomatic, hisat2 and deseq2”. I am not 100% sure but I don’t think it is possible to request this much extra space. The recommendation would be to set up your own galaxy server (Account quotas - Galaxy Community Hub). Maybe this can also help Managing Datasets in Galaxy - Galaxy Community Hub. If you really need a reply from an admin you could try to make a new topic or use a diffent way to contact, see: Account quotas - Galaxy Community Hub

1 Like

Thanks, I have sent several mails to the email listed in the "Account quotas- Galaxy Community Hub, but no response detailing all of the above information requested as seen below. I am wondering if there could be another email address with which I can reach the admin for this request. Thank you.


  • If your work is academic research based and additional short-term space is needed at Galaxy Main (, please send an email to from your registered account email address, briefly explaining your project and we may be able to help."

Dear All,
I ran some jobs on galaxy server, but when I tried checking them after completion, I got the message in the screen shot, what could be the problem? Thank you


We wrote you back about the request. You needed to purge older work to free up space for new work. Please remember that this forum is public, and avoid posting anything private like your email address.

Account data usage can be reviewed and managed under: User → Preferences → Storage Dashboard

The connection problem you had was temporary and the server is now up. Server status can be checked at:

Most tools in Galaxy will expect a specific fastq format given the datatype “fastqsanger”.

If there is a new problem or if you need more help, please ask a new question and include the server URL and describe what is going wrong. FAQ: How to ask a question others can help with

1 Like