Flye Asembly limits

Hi, i hava multiple fastq files from Nanopore data and i want to use FLYE ASSEMBLY ; Individual files (~500MB) works but when i use a unique file (3,5GB) i can’t use the file (Unavailable) for FLYE…
There is a limit (1GB) for using FLYE?
Do you have any tips to resolve this problem?

Thank’s to the Community.

1 Like

Update:

Oh, ok, you are referring to an ONT dataset that includes UMIs. Sorry, blanked on the association. Those data need to be parsed out first into sequence groups before assembly when using this tool.

usegalaxy.org does not have all of the newer wrapped nanopore tools, and this particular tool doesn’t accept data in the original format (doesn’t split the assembly into groups automatically by UMIs).

The good news is that usegalaxy.eu does include more nanopore tools. Search in the tool panel with the keyword “UMI” or “nanopore” to find the tools. Or, even better, use the domain-specific server nanopore.usegalaxy.org (NanoGalaxy). That server hosts a subset of tools appropriate for this type of analysis plus workflows and related resources. Your account at usegalaxy.eu and nanopore.UseGalaxy.org will be the same, but distinct from accounts at servers without the “usegalaxy.eu” URL. Create one new account at one the EU servers if you don’t have one already – it doesn’t matter which, the account is connected across all of the sub-domain servers.


Welcome @ipoutcha_thomas

There is no input filter based on data size that I am aware of, but it could be a custom setting where you are working. That said, very large inputs could fail with any tool – it depends on the resources allocated to the tool at the server you are working at. But that kind of resource failure would show up after the job attempts to run. Public Galaxy servers have significant but sometimes limited resources allocated for some tools, usually for practical reasons. Your own cloud or another deployment choice could be configured to allocate more resources for very large work.

I’m not sure what a “unique file” means, but these are the first things to check. I suspect one or more of these is the actual problem:

  1. Is this a dataset collection input? If so, set the input to be a collection (“folder” icon next to the input select menu) on the tool form.
  2. Does the input have an accepted datatype assigned? To review which datatypes are valid for any input, any tool: Create a new empty history, load up the tool form, and the select field will list out the accepted input datatypes.
  3. Was the input shared with you by another person and imported into your history? They may have granted you read-only permissions. Have them share the data with you again, granting full permissions so you can work with it.
  4. Make sure you are using the most current version of the tool, and that the inputs are in an active state (not deleted or purged). Datasets included in a collection are hidden by default, and that is fine, but you might want to check them. Toggle the show/hide hidden datasets at the top of the history panel.

Let’s start there. If you need more help, please post back a few more details:

  1. Where are you working? URL if a public Galaxy server or describe if another deployment.
  2. What version of the tool are you using? This is noted at the top of the tool form. Paste back the full name/version.
  3. What is the assigned datatype of the inputs? Are these in a collection?
  4. Screenshots may help. Try to capture the entire browser window, including the URL, expanded/unhidden input datasets in the history panel, and the tool form with the “unavailable” message.

Thanks!