FTP connection error with FileZilla

I am trying to connect to galaxy via filezilla but i am getting this error message:

|Status:      |Resolving address of usegalaxy.org|

|—|---|
|Status: |Connecting to 129.114.60.60:21…|
|Status: |Connection established, waiting for welcome message…|
|Status: |Initializing TLS…|
|Status: |Verifying certificate…|
|Status: |TLS connection established.|
|Status: |Logged in|
|Status: |Retrieving directory listing…|
|Command:|PWD|
|Response: |257 “/” is the current directory|
|Command:|TYPE I|
|Response: |200 Type set to I|
|Command:|PASV|
|Response: |227 Entering Passive Mode (129,114,60,60,118,163).|
|Command:|MLSD|
|Error: |Connection timed out after 20 seconds of inactivity|
|Error: |Failed to retrieve directory listing|
|Status: |Disconnected from server|
|Status: |Resolving address of usegalaxy.org|
|Status: |Connecting to 129.114.60.56:21…|
|Status: |Connection established, waiting for welcome message…|
|Status: |Initializing TLS…|
|Status: |Verifying certificate…|
|Status: |TLS connection established.|
|Status: |Logged in|
|Status: |Retrieving directory listing…|
|Command:|PWD|
|Response: |257 “/” is the current directory|
|Command:|TYPE I|
|Response: |200 Type set to I|
|Command:|PASV|
|Response: |227 Entering Passive Mode (129,114,60,56,120,136).|
|Command:|MLSD|
|Error: |Connection timed out after 20 seconds of inactivity|
|Error: |Failed to retrieve directory listing|

Hello @tamerbio

Please try again if you have not already. FTP at usegalaxy.org is working from remote locations now, and the server didn’t have any known issues around this function when you wrote in. But, perhaps the connection was poor. Or, you did not click to accept the secure certificate pop-up before the connection timed out?

FAQ: https://galaxyproject.org/ftp-upload/

Thanks!

Hi Jennaj,
Thank you so much for your reply. I check FileZilla on Mac and Windows OS and still failed to log into FTP.

1 Like

Hi @tamerbio

The service is definitely up.

The FAQ has examples, but this is some more troubleshooting help that usually solves problems:

  1. Make sure you are using the latest version of Filezilla. The tool updates quite frequently and will prompt you to update when the app is opened. Those updates install quickly. I tend to just replace my current version with the update – but I also don’t set up any special configurations (on purpose) – so I can’t tell you if those are preserved or not after an update with the latest version. You could test it out or review/ask for help from those app developers if this is a concern. There are many FTP clients, and it can be used command-line – the FAQ I sent has more help about that.

  2. Try using all default settings. The connection will still be secure when connecting to usegalaxy.org. You’ll be prompted to accept the security certificate when the connection starts up.

  3. Make sure to connect with your Galaxy registered email address as your Filezilla “username”. Your Galaxy “public name” won’t connect. The “password” is the same as used when logging into that same exact Galaxy server for that same account.

  4. The FTP server name aka “host” will vary by the Galaxy server – sometimes it is the server’s base URL (and that is true for “usegalaxy.org”) – and sometimes it is different. What to use is likely posted within the Upload tool for the server in the button > pop-up for the FTP function (tool used move FTP’d files into a history as datasets). Another place to check is the server’s homepage. If you cannot find it – you can ask here (we might know based on the public Galaxy server’s URL) or you can contact those server administrators directly – not all follow this forum. Contact information for public Galaxy servers is often on the server’s home page and/or in their directory listing here: https://galaxyproject.org/use/

  5. Do not enter a “port” for most cases (including usegalaxy.org). Advanced configuration is different – and the FAQ linked before has details about that. But you don’t need to do that – defaults work fine for most people.

  6. If the data transfer stalls out while in progress, which files failed is noted near the bottom of the Filezilla app in the tabs. Timeouts can happen with slower connections or larger datasets and it is possible to resume the transfer where it left off within Filezilla. Note that this will usually prompt another security certificate pop-up. Click to accept each time.

  7. If you are transferring many files and having problems, try transferring less files at a time. The transfer will only go as fast as your internet connection allows. University and business wifi connection speed is usually much faster than home wifi or cellular connection speeds. For personal internet/cell, most ISPs maximize “down” transfer speeds – and “up” data transfers can be much slower – for the same service. There are many “speedtests” available – an internet search will find them if you want to check yours.

  8. Some universities or businesses block sending data outside of the “intranet” entirely and others may only block some external sites for security purposes. If you think that usegalaxy.org is being blocked, contact your local administrators.

  9. Some home/cell ISPs may also block or throttle where and/or how much data can be transferred. Total or within a given time window. Contact your ISP for help if you think that is the problem.

  10. Review prior Q&A about FTP at this forum. Search with the keyword “ftp” to find those topics. You can also review prior Q&A at our older forum. The second post in this search is an identical issue to what you have, and using “all defaults” solved their problem: https://galaxyproject.org/support/ >> Galaxy Biostars: retired Q&A archive >> add “ftp” (or “msld”, part of the error message) into the keyword search already including “biostar” >> https://galaxyproject.org/search/?q=biostar+MLSD#gsc.tab=0&gsc.q=biostar%20MLSD&gsc.page=1 >> https://biostar.usegalaxy.org/p/24134.1.html

Hope that helps! I don’t think everything was in one post before, so maybe will help others too.