FTP Upload Fail - No certificates popped up


I am a new user to Galaxy in general and have been using the main Galaxy server (http://usegalaxy.org/). So far I have been successfully uploading my data to the main Galaxy server through FTP. Previously, I used Fillezilla to upload my data and it working fine so far. I also have had success uploading my data to Galaxy.eu using the FTP but this few days, I could not connect to the server.

Status: Resolving address of ftp.usegalaxy.eu
Status: Connecting to…
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server
Status: Waiting to retry…

I read some of the previous post and the tutorial, it might be because of my internet connection. So I tried connect to the main server at the same time, it worked well, so does the problems come from my internet ? I’m a bit confused now. The connection keep failing and I also realised that there are not certificate popped up whenever I tried using the galaxy.eu. How do I changed the settings so I can find the certificate?

I checked all the settings and my login info also the same with the Galaxy, so I think no problems with it. Can anyone pointed of what should I do now?

Many thanks,

Hi @Amirah
the instructions to use the FTP server are available at this address, Galaxy Europe | FTP service instructions
The last part of the IP showed in your log, suggest me that you are using a different setting from the one described in the documentation above.

From a few days, we have also deployed a new upload mechanism through the web interface, so my suggestion is to give it a try as well.

Regard your question about the certificate, it’s not clear to me what you mean. The official URL of the European Galaxy server is https://usegalaxy.eu and is handled with an SSL certificate properly showed

Hi @gmauro
Thank you for answering. I have tried again using the documentation you mentioned. However, I encountered this error now.

Status: Connecting to…
Status: Connection established, waiting for welcome message…
Response: 220-incoming.galaxyproject.eu FTP server
Response: Unauthorized access is prohibited
Response: 220 FTP Server ready.
Command: AUTH TLS
Response: 504 Command not implemented for that parameter
Command: AUTH SSL
Response: 504 Command not implemented for that parameter
Status: Insecure server, it does not support FTP over TLS.
Command: USER amirahfaruq@gmail.com
Response: 550 SSL/TLS required on the control channel
Error: Could not connect to server

Is my setting still incorrect or could be other issue, can you help pointed where do I go wrong?

Not sure what could be but, before to go trying to debug the FTP connection, I strongly suggest you to try the upload tool from the web interface. With the new Galaxy release just deployed, we integrated a new upload framework that should work pretty fine.

Alright, thank you for your help.
I’m going to try the upload tool from the web interface and see how it goes.