gemini database download error

Hello, I have tried to download gemini database through the gemini data manager, and encountered an error related…

After everything has been downloaded… it seems like python script failed…
There were no options to change besides some optional one which are part of database information (and failed as well when checked them, with the same error as well)
Does anyone knows how to help me?

1 Like

Oops, that is the consequence of an unpinned pyyaml dependency in the gemini bioconda recipe and https://github.com/yaml/pyyaml/pull/561.

I’ll try to get a fix for the DM ready today or tomorrow.

If it’s super-urgent, you could also patch the line of code mentioned in the traceback to provide the “Loader” argument.

one question though: can you provide a bit of details on how you’ve been installing the DM’s dependencies and on which system?
Since gemini requires python2 and conda doesn’t have a python2-build of pyyaml > 5.3.1, you should only see a Warning, but no error w.r.t. the Loader.
Can you check which versions of gemini and pyyaml you have ended up with?

1 Like