Genome of interest not listed for using HISAT2

Hello Community Members

The genome that I need to map my reads to is not listed in the reference genome list while using HISAT2. Can anyone share with me the procedure to index my required reference in HISAT2 genome list? Is it alright if I directly upload a fasta file for the reference genome from my PC to the history and use the same as a reference genome?

Following is the NCBI link for the reference genome of the microorganism that I am working with

Thank you for any help

1 Like

Hi! I had the same problem and I used an FTP genome that I uploaded from my computer. It worked for HISAT2 so I think it might also work for you.
Have a good one


Hi @abhilash719,
as Stefania stated, you can upload your reference genome via FTP. The following tutorial explains the procedure for uploading files using this protocol: File Upload via FTP. Then you can select it in the HISAT2 tool by selecting the Use a genome from history option.

1 Like

Thank you, Stefania.

Thank you, Gallardo.

1 Like

Hi Gallardo

I am unable to upload the genome via ftp. It’s saying your connection to this site is not private. I think chrome does not support FTP anymore. Is it alright if I just download the genome from NCBI upload it from my PC? The size of the genome is only 4MB.

Hi @abhilash719,
you can just copy the Desulfovibio alaskensis reference genome FTP URL from the NCBI FTP server and paste it in the Galaxy uploader (Paste/Fetch data).

1 Like

Thank you again, Gallardo.