(HiCPlotTAD)This will generate an empty track!!

I am trying to plot TADs using the HiCPlotTADs tool in usegalaxy.eu, but I keep receiving the same error.

INFO:pygenometracks.tracksClass:plotting 1. [x-axis]
INFO:pygenometracks.tracksClass:plotting 2. [hic matrix]
There is no data for the region considered on the matrix. This will generate an empty track!!

In the provided .ini file, I did use the H5 file produced by Hicexplorer. Why is the matrix still empty?

Hi @s10101282

You sent in a bug report to the UseGalaxy.org team a few days ago, correct?

Did you enter a valid region onto the form? Is the format Ok? Do you know if the file contains data in that exact region? The tool doesn’t think so … so maybe the region entered has some problem. Mismatched chromosome identifiers would be one guess.

Hello, because I am exploring the changes in chromosomes related to antiviral genes, for example: I want to examine “DDX58,” so I have set up the command:

pyGenomeTracks --tracks Mock_tracks.ini --region 9:32400000-32500000 -o image.png

However, it keeps failing. :((((((

Hi @s10101282

Is the chromosome named like 9 or like chr9?

Your command has the first format specified but many genomes indexed in Galaxy were sourced from UCSC, so use the latter format.

This is a gotcha for everyone, but the short advice is to just double check your own data to make sure that everything is based off of the same exact genome assembly release to avoid problems (may not even fail a tool, and instead produce odd scientific results). Mismatched Chromosome identifiers and how to avoid them

Thank you for being willing to answer my questions. I tried the following syntax again, but it still doesn’t work. :(((((

pyGenomeTracks --tracks Mock_track1017.ini --region chr9:32400000-32500000 -o Mock_image.png

Hi @s10101282

Could you run this tool please? I’m wondering if your data is not mapped/annotated yet, and this report would reveal that case.

hicInfo get information about the content of a Hi-C matrix

And, if it is annotated, what was the target reference genome? Custom genome? Locally cashed? Which? Does that chr9 actually exist in that reference genome? At those coordinates? Did you expect data to map there (some tutorial data may be limited to other genome regions)?

Are you following a tutorial? Which? And, if you are not following a tutorial yet, this is a good place to start: Hi-C analysis of Drosophila melanogaster cells using HiCExplorer

Hello, the information obtained using “hicInfo” is as follows:

(hicexplorer_env) lab@lab-VirtualBox:~$ hicInfo -m 1017hicCorrectMatrix_Mock.h5
# Matrix information file. Created with HiCExplorer's hicInfo version 3.7.2
File:	1017hicCorrectMatrix_Mock.h5
Size:	3,086
Bin_length:	1000000
Sum of matrix:	288752625.1602878
Chromosomes:length: chr1: 248956422 bp; chr2: 242000000 bp; chr3: 198000000 bp; chr4: 190000000 bp; chr5: 181538259 bp; chr6: 170805979 bp; chr7: 159000000 bp; chr8: 145000000 bp; chr9: 138000000 bp; chr10: 133797422 bp; chr11: 135000000 bp; chr12: 133000000 bp; chr13: 114000000 bp; chr14: 107000000 bp; chr15: 101991189 bp; chr16: 90000000 bp; chr17: 83000000 bp; chr18: 80000000 bp; chr19: 58617616 bp; chr20: 64000000 bp; chr21: 46709983 bp; chr22: 50818468 bp; chrX: 156000000 bp; chrY: 57000000 bp; 
Non-zero elements:	8,238,824
Minimum (non zero):	0.2608818257027453
Maximum:	135425.64264647412
NaN bins:	131

However, for the subsequent HicPlotTADs, I used pyGenomeTracks.

Yes, the tutorial I followed initially was based on this.

Hi @s10101282

Are you running the tool in Galaxy?

If not, maybe try and see if the Galaxy tool works? The command line would be part of the output, and you could compare your local string to the Galaxy string and maybe spot an important difference.

The only other item I can think of is some problem with the configuration of the tool outside of Galaxy.

Hi @jennaj
Thank you very much for your help.
Later on, I wanted to try if I could correctly visualize the matrix from my original hic-data H5 file.
It feels like I succeeded (comparing it to the empty matrix I had before, haha…). However, the output result is still very strange.

Here is my code for this time

pyGenomeTracks --tracks hic_track.ini -o 101901hic_track.png --region chrX:2500000-3500000
INFO:pygenometracks.tracksClass:initialize 1. [x-axis]
INFO:pygenometracks.tracksClass:initialize 2. [hic matrix]
INFO:pygenometracks.tracksClass:time initializing track(s):
DEBUG:pygenometracks.tracksClass:Figure size in cm is 40 x 23.86279692855858. Dpi is set to 72

INFO:pygenometracks.tracksClass:plotting 1. [x-axis]
INFO:pygenometracks.tracksClass:plotting 2. [hic matrix]
INFO:pygenometracks.tracks.GenomeTrack:setting min, max values for track 2. [hic matrix] to: 61757.57107070611, 17540.482597922633
where = top

[hic matrix]
file = 1019Mock_KR.h5
title = hic_data
# depth is the maximum distance plotted in bp. In Hi-C tracks
# the height of the track is calculated based on the depth such
# that the matrix does not look deformed
depth = 1250000
transform = log1p
file_type = hic_matrix

I really appreciate your help.

Indeed pyGenomeTracks and HiCPlotTADs are the same. As this seems more linked to the tool than galaxy. Do not hesitate to write an issue in Sign in to GitHub · GitHub I will be happy to answer you.
Lucille (main developer of pyGenomeTracks)


Hi @lldelisle
Thank you very much for your response. Yes, I have also asked related questions on GitHub, but no one has responded.

I’ve just replied.