History Contains Invisible Files That Cannot Be Purged

I have a single history within my account that reports as having 64 shown, 1415 deleted, and 1365 hidden datasets. However, I can only see 296 datasets (even after revealing hidden datasets). I have tried purging deleted datasets - it reports that 0 datasets have been purged. I do not know why the deleted datasets remain associated with my history? In addition, I do not know where the other ~1050 hidden datasets are, but they are taking up the majority of my galaxy diskspace. My history reports that there are multiple pages when viewing hidden datasets, however, if I click to “move to page 2” nothing loads - not even the history name. I have to move to a new browser page to get my history to reload.

I do not want to delete this history - I am not done with the analysis. However, I have not found a way of exporting specific datasets to a new history so that I can delete the whole dataset. Equally, I cannot do any more analysis because my diskspace is full.

Any ideas?

1 Like

Find all Histories and purge (aka permenently delete) those not needed.

  • Under the Histories Options (gear icon, top of right History panel), choose Saved Histories from the list.
  • Click on Advanced Search , then choose status = all .
  • Locate deleted but not permemently deleted histories and purge them.
2 Likes

Hi Amir,

Almost all histories listed there were marked as “permanently deleted” . The handful that were marked as “deleted” were few, and had no files in them (unnamed histories). Deleting these few didn’t free up any space.

The only active history listed there is my current history. It looks like the attached image. There are literally 1000 files that cannot be found within the history. I can’t see them to delete them (even after clicking view hidden, view deleted etc).

1 Like

Try refreshing your session by clicking on the upper left “Galaxy” icon.

Logging out, then back in again will also refresh the session.

When tabbing through pages, avoid using the “Operations of multiple datasets” function first. Do that after the page is loaded. Then you can check off the ones you want to change the status for using those “Operations” menu choices.

There are a few ways to do this: unhide all hidden, change active datasets to deleted, make datasets permanently deleted. Or, just do the first two on each page, then back out into the default view, and use the history menu option “Purge deleted datasets” to get rid of all currently marked as deleted in batch moved to the purged state.

Hope that helps!

i had this problem once but i dont remember exactly how i done that. i did take a look now and i suggest some way which i think is easer way than the one @jennaj suggested.
Click view histories on the top right of galaxy, it looks like a book, then you see “…” on top . click on that and select "include deleted histories. and purge them from there,
i hope this work .

1 Like

Great advice @amir That should work, too.

Plus you can show/hide deleted or hidden datasets at the top of the history panel. But that seems to have caused problems in the single history view, especially when scrolling through pages. Unless the session refresh fixed things up enough for that to work.

So … a few ways to do this.

How to make working with really large histories easier is something we are working to improve on the backend/database side first, then the web forms will be adjusted to use the improved methods. This will all start to show up over the next 6 months or so. Much is being refactored/updated to better handle larger/more numerous data in web displays/functions.

2 posts were split to a new topic: My usage quota seems incorrect