How long does history export take???

I have been attempting to download my history but it shows “Galaxy server is preparing history for download, this will likely take a while…” for the past 4-5 days!

I understand that my history is large (~175GB) but there seems to be no way for me to see how much of it is completed or if it is going to error out eventually.

Moreover, is it OK to work on Galaxy while this history export is ongoing?

1 Like

Hi @Fizz

Larger histories will take longer to compress into an archive. Are you working at a public Galaxy server? Please post back the server URL for context.

It is fine to navigate away then come back to check status. The message and final link will update when ready. After 5 days, you might want to do this anyway to refresh the view (consider clearing the browser cache first).

Alternatives include downloading individual datasets and extracting/exporting a workflow that can reproduce any intermediate files not downloaded.

Hi Jennaj,

I am using the EU server I have tried the option you suggested but it is not yet ready.

An indication of how much of the export is complete would be welcome!


Hi @Fizz

Thanks that helps! The server will run archive jobs a bit longer than at the other sites.

The progress is tricky to capture and report. Please try to let this complete, then follow up if the result errors.

Small note: if the history contained many deleted/purged datasets, creating a copy of a history that excludes deleted datasets then extracting a history archive from that simplified copy might work better/faster. You could try this at the same time if wanted – find the function under the History Options menu → Copy this History.

ping @gallardoalba @wm75

I tried “Copy this History”, but it seems to be working in the foreground. When I click on any part of the page, that pop-up disappears and I have no way of knowing whether it is working any longer.

Copies are made very quickly. Find the copy in your listing at User → Histories.

Copy history sure does work fast! However, when I tried to send the new history to a file or to a link, it failed.

I’m not able to reproduce a history export failing on a “copy of a history that is also being exported” at that server.

Please try again, making sure that the history being exported has a unique name first. Should that still fail, capture a screenshot of the error message/pop-up and post that back.

Smaller history is being exported since yesterday.

Hi Jenna,

I get a request failed error when I try to download the history.

Hi @Fizz

Odd. Let’s ping the EU folks again: @gallardoalba @wm75

@jennaj not a good time for debugging this feature atm. History exports (using celery on .eu) are completely broken since upgrading to 23.0 yesterday.
@Fizz that’s why you’re seeing only failures now.
Unfortunately, this is a bivger issue to tackle so please give us a few days. I’ll post updates here.

1 Like

Thanks for the update. Prevents me from spamming the download button :sweat_smile: