How to 'force=TRUE' in Human Methylation BeadChip module

Hello everybody,

I am very new to Galaxy and hope for help with a - most likely - very trivial problem. I am trying to run the Infinium Human Methylation BeadChip module according to the respective Tutorial but using my own data. Unfortunately, I now encountered the error:

“(…)
Error in read.metharray(list.files(pattern = “_Red.idat”)) :
[read.metharray] Trying to parse IDAT files with different array size but seemingly all of the same type.
You can force this by ‘force=TRUE’, see the man page ?read.metharray
Execution halted”

According to what I found in the Bioconductor forum, this seems to happen quite regularly with EPIC data and it should be okay to try the ‘force=TRUE’. But, unfortunately, I do not know how to adjust this setting using Galaxy.

Any advice would be very welcome!

Many thanks in advance and best wishes,
Lea

Hi @ljflitsch,
I opened a PR in order to include this option in the Galaxy wrapper.

Regards

Hey,
@gallardoalba: Thank you very much for your help and effort. Since I am really new to this topic: Is there any way to get notified once this option becomes actually usable in Galaxy as an ‘end user’? E.g. anything/anywhere I can ‘follow’ to receive updates on this matter (perhaps via registering at GitHub)? Sorry for any inconveniences and best regards!

Yes, if you leave a comment in the PR, it will notify the news related to it.

Regards

Will do so. Thank you very much.