How to solve this problem? (RNA STAR index in Galaxy Docker)

For using RNA STAR aligner, I downloaded hg19 ucsc fasta via ‘DBkey and reference genome’.

Then, I ran RNA STAR Index builder. But, I got next error message.

"EXITING because of FATAL PARAMETER ERROR: limitGenomeGenerateRAM=4001000000is too small for your genome
SOLUTION: please specify --limitGenomeGenerateRAM not less than 8404712832 and make that much RAM available "

When I saw the command line, I checked ‘limitGenomeGenerateRAM=4001000000’,

but, since my own computing system has enough memory (about 200Gb), I don’t understand it.

Can I modify this command line manually on Galaxy Docker?

This may be a limit set in your Docker environment. If you run docker info, there will be a line saying Total memory that will tell you how much memory is available to Docker containers. If you are using Docker on a Mac or Windows, there is a setting in the preferences that defines what the max value is.

If the Docker system offers enough memory, you can set the amount of memory available to the Docker container by running it with something like docker run --memory=”16g” ...

Dear enis.

Thank you for your prompt rely. According to your suggestion, I tried to perform ‘Galaxy Docker’ with the next command line 'docker run --memory=‘100g’ …

When I ran docker info, I saw Total memory of my system is 180Gb.

But, it didn’t work. I got the same error message. Could you suggest any other solution?