htseq-count configuration problem

I am having a problem with the installation a local instance of Galaxy using htseq-count. The cloning took a long time to set up, more than with other things I have installed. With a hisat2 derived BAM file generated from primary sequencing data, genomes, and gff files that ran fine on the public Galaxy server I get the following message:

Dataset Error
An error occured while running the tool

Tool execution generated the following messages:

Fatal error: Exit code 127 (Unknown error occurred)
samtools: error while loading shared libraries: cannot open shared object file: No such file or directory

It seems that samtools is not configured to do something correctly. Not finding a genome index? The public Galaxy doesn’t require this be done manually. How is this different in the local instance?

I checked the dependency tool manager. Htseq-count dependencies htseq 0.9.1 and samtools 1.7 had green checks next to them. The previous step in the analysis, hisat2, had dependencies samtools 1.9 and seqtk 1.3 green checked and it worked fine on both the public Galaxy and my local instance.

This is a critical tool. Any help in getting this set up properly would be appreciated.


1 Like


This means that the dependencies did not install correctly. Please see this post for prior Q&A about the same issue:

Gitter hasn’t responded to a query about the samtools error. In searching out alternatives I found htseq-count is a module of htseq, which that the version in Galaxy hasn’t been updated since 2017-07-11, is not the latest version of the program. Version 11.0.1 came out 2019 01-03. Documentation is at It looks like it is downloaded from For the stand-alone application, the NumPy - a python numeric caculation package, Pysam - an interface to Samtools (no version specified), and Matplotlib - a plotting program ( probably not needed if output is to tables). Do you know if anybody has tried integrating this version into Galaxy? If so, how would I go about doing it on my local instance?

1 Like

Yes, this is the version of the tool installed at all of the usegalaxy.* servers.

Did you check your conda to make sure it is current and being used by Galaxy? (see the linked post in my original post and the reply from @nsoranzo). Your dependency resolvers might also need some tuning, even if you are already current with conda, see:

Also, are you updated to the latest Galaxy release (19.01)? If yes and that was done some time ago, check for point updates (are usually bug/security fixes) and update. If not at this release yet, please consider upgrading. Either could help resolve the tool install issues.

For the updated stand-alone tool, that would need to be wrapped to use it in Galaxy. See the ToolShed for where to find the current tool development repository if you want to help out with the wrapper update (last updated about a year ago), or to make a new issue request to the IUC to have the tool updated.