Input format problems with tools

Could someone please post a more specific solution for this problem? I’m having the same issue with a different tool. Can’t seem to get Galaxy to recognize the header in a sensible way. @Amalie how did you solve it?

1 Like

Welcome @ncarrut

This FAQ covers the most common problems with differential expression tools/analysis. Please review to see if it helps.

If you cannot determine the problem, please clarify your issue a bit more. I did move it into a new topic since you stated that you are using a different tool.

  1. Where are you working? If a public server, share the base URL
  2. What tool are you using? Copy the full name, including version, from the top of the tool form.
  3. Which option on that tool form are you submitting the input file to?
  4. What is the currently assigned datatype of your input?
  5. Did you assign the datatype yourself or did you allow Galaxy to “autodetect” when uploading?
  6. What datatype is assigned if you redetect by clicking on the pencil icon (upper right corner of the dataset), go to the Edit Attributes forms, tab into “Datatypes” and use the button to “Auto-detect” again?
  7. If you want to share a few lines of your file, including the header, that would be helpful.

Let’s start there, thanks!

Thanks for the response:

  2. MaxQuant (Galaxy Version
  3. I’m submitting an experimental design to the Search Options form
  4. tsv
  5. I assigned it myself
  6. autodetect doesn’t change it from tsv
  7. The file is below. I cut and pasted from my history:
1.Name 2.Fraction 3.Experiment 4.PTM
Name Fraction Experiment PTM
2047_fin_1 1
2047_fin_2 2
2047_fin_21 21
2047_fin_22 22

The original file was:

Name	Fraction	Experiment	PTM
2047_fin_1		1	
2047_fin_2		2	
2047_fin_21		21	
2047_fin_22		22	

The import added an extra line that creates an error when I run:
Template of the MaxQuant parameter file ‘/data/dnb02/galaxy_db/job_working_directory/006/194/6194111/working/mqpar.xml’ is created.
Traceback (most recent call last):
File “/opt/galaxy/shed_tools/”, line 110, in
m.add_infiles([os.path.join(os.getcwd(), name) for name in fnames_with_ext], True)
File “/opt/galaxy/shed_tools/”, line 186, in add_infiles
design = self._make_exp_design(infiles)
File “/opt/galaxy/shed_tools/”, line 147, in _make_exp_design
MQParam._check_validity(design, len(infiles))
File “/opt/galaxy/shed_tools/”, line 80, in _check_validity
raise Exception(msg + " Name or Experiment is empty.")
Exception: Error in line 2 of experimental design: Name or Experiment is empty.

Valid input according to MaxQuant is below:
Currently four columns are needed: Name, Fraction, Experiment and PTM. The headers must have this exact naming. Name and Experiment are abitrary strings, Fraction is an integer or emtpy, PTM is either ‘True’, ‘False’ or empty. Consider you uploaded files named File1.mzxml, …, File5.mzxml. This is a (syntactically) correct experimental design template:

Name     Fraction    Experiment   PTM
File1        1          E1       False
File2        2          E1       False
1 Like

Hi @ncarrut

This is tabular data, not tsv. Using “autodetect” is guessing the wrong type, probably because of the internal blank values. Assign tabular directly. BUT – Upload it again to get rid of the extra line at the end. Or, try the tool Select using “not matching” and one of these regular expressions: ^$ or ^\s*$

When pasting data into the Upload tool, it loads exactly what you enter. Avoid extra trailing whitespace on lines or extra empty lines at the end.

If you can’t get that right, then skip the “paste” option, and create the file locally first, confirm format in a tool that allows you to inspect whitespace in a clear way (vi, vim, emacs are best IMO; possibly “TextEdit” but it won’t be as precise), and Upload that file directly.

As far as I know, in the Galaxy wrapped version of the tool only Name and Experiment are required values in data lines, but the header should include all.