Installation in Ubuntu Server LTS 22.04


I was wondering if anyone has more detailed instructions on installing a local instance of galaxy server (release 23.0) on an Ubuntu server LTS 22.04.

I have tried the straightforward approach outlined in the Galaxy documentation here, but it has failed several times. The folder downloads from github without issue, but when I use sh the installation takes about 10 - 20 minutes before resulting in an error message. I’ve received:

  • error code exit 1,
  • error code exit 134, and
  • a repeating attempt to synchronize and wake up “celery-beat” that never resolves.
==> ../log/celery-beat.log <==
[2023-06-21 09:49:02,380: DEBUG/MainProcess] beat: Synchronizing schedule…
[2023-06-21 09:49:02,387: DEBUG/MainProcess] beat: Waking up in 5.00 minutes.

Perhaps it’s a dependency issue, and it would be very helpful to know which packages for Ubuntu should be pre-installed before attempting the Galaxy build. For example, I know python is required, but what version? What other packages would be required for a successful build?

If someone has built a galaxy server on Ubuntu and wouldn’t mind sharing their steps, I’d be very thankful!

Forgive me if this is a naive question; I’m very new to this.

Thanks in advance!

Welcome, @pjlombardo

These are better resources. Be sure to install Galaxy into a Conda .venv. Why is in the admin docs under Framework Dependencies.

That said, if this is just for your own use, the Docker version comes with much preconfigured and is usually easier to apply customizations to. But you can review the choices and decide.

Hello pjlombardo,
I have to say that I have yet to find any good documentation on doing a local install of Galaxy. That said, I’m attaching my own notes on how I installed Galaxy. It has gotten me to a running state but my main issue is not getting Jbrowse to install. What I learned in my many install attempts is permission, permission. It always bites you in the ass. Just make sure to create a local non-root Galaxy user account. Use that account to install Galaxy. Then if you use Nginx to proxy all SSL connections, make sure Nginx account has access to the Galaxy home folder. Now that I think about it. It might be a better idea to simply install Galaxy as the Nginx account. Might try that next.
Attaching my notes here, Just jump down to the Ubuntu install, keep in mind my home folder path changed during my install attempts on different OS platforms. Also, you will use sections 3 and 4 on Galaxy config changes and Nginx config settings.
Let me know if this helped or made things worse. Hopefully not worse.
Install notes

Hi @cjkeist,

I couldn’t access the notes you attached. It said “this shared folder has been removed or is unavailable to you” when I created a box account. Is there a different way to access the notes?


Thanks Jennifer, I’ll dive into these today!


Based on the helpful suggestions from @cjkeist and @jennaj, I am now installing through a Conda .venv for a non-root galaxy user. Unfortunately, it still won’t build.

Everything seems to be going well until it stalls at:

$ GXY_BUILD_SOURCEMAPS=1 NODE_ENV=production webpack
Browserslist: caniuse-lite is outdated. Please run:
   npx update-browserslist-db@latest

I have run the suggested command several times, and I’m told that it is up to date. I also tried re-installing yarn and npm to make sure they’re both up to date. I have even double checked that my current version of caniuse-lite is the most recent. I’m not sure why it gets stuck at this point.

The build essentially stalls at this prompt and then eventually throws an error 134, and some message about javascript heap out of memory?

Any thoughts? Has anyone else seen this?

Sorry, the link did work. Didn’t realize it would require a Box account. I set it so anyone with the URL should be able to download it. Annoying this forum doesn’t allow pdf files to upload. Anyway, try this link.


Thanks @cjkeist, this download worked perfectly. I’ll try the install soon.

1 Like