megaBLAST python wrapper error?

I ran a test file (xxx.txt) containing fasta formatted sequences that I uploaded from my desktop. There are only <10 sequences in the file. I wanted to test this because I was having issues with running megaBLAST on a larger dataset collection. At any rate, I think there is something happening with this python script that is causing megaBLAST to fail with large or small files.

This was the error message:

File “/project/galaxy/galaxy-py3/galaxy-base/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/megablast_wrapper/fb2e0e1dac89/megablast_wrapper/megablast_wrapper.py”, line 68
print megablast_command
^
SyntaxError: Missing parentheses in call to ‘print’. Did you mean print(megablast_command)?

I also tried to upload a pic of the error screen, not sure if it made it…

This was the input file (for some reason it’s not seeing the >'s at the start of each sequence title, but they are on there):

A00129:980:H5TVGDSX2:4:1107:23547:158121:N:0:TGTCGCAT+AAGCTGAC
TAGTAGATTTAAAACGAAGGTCTTGGGGGGTGGTACTTCCCTCAATTCCAATAACCTAAAATAAAATTAAAATTAATAAGTATTTAAAATTTAATATTACGCGCTAGCGTAACATCTGACATCCATTTCTTCCCATGTGATAAGGT
A00129:980:H5TVGDSX2:4:1114:6777:151701:N:0:TGTCGCAT+AAGCTGAC
GTCGGAATGGAATCGTAAATTGGACGGGACTTATACTAAATATTCTAGTCTTACCAGGTATTCTGCATTTTTCCACAGGCACACATGTATCTTTCAAACAATCCGTGAATATAGTGTGAGGCTTTATTCCCTTCTTCCTCATTAACTGAG
A00129:980:H5TVGDSX2:4:1124:1524:98311:N:0:TGTCGCAT+AAGCTGAC
CACCTAACCTAGAGTACCACTTTAATCGTAACTAAAACTACTCTACTACGGAGCTGAGTCTTTAGAGGCAACTCAACCTTCCTCACATATAAGCTAAAAGTGGTGGTCTAATCCACTCTGCTTTTAGACTCTTATATGCAAGTTCACTCC
A00129:980:H5TVGDSX2:4:1126:11279:367461:N:0:TGTCGCAT+AAGCTGAC
ACCCCATCCGAATGCCAACTCTAGCGCTTGTTTAGCATTCTCAATGGTTGCTACTCGACGACCCAATCCTCGAGCATGTGTCCAATTGGTTGTTCCTTCTATAGAAACATTATCCAGATTGGCTAGAAACACGGGTCTTGTTGGATGTTT
A00129:980:H5TVGDSX2:4:1127:7699:341781:N:0:TGTCGCAT+AAGCTGAC
CGGATAAAGGCAAATCAGTAATACCTAACCAAGCTAACCTAATTAACAAACAATTTGAAATTGTATTCAATATGTCCGTTATTGGAGAACCTGATGGAATTCCGCAAGGTACTCGGTACACCAAATCGCGACATAGATGACTAGGCG
A00129:980:H5TVGDSX2:4:1140:5041:243771:N:0:TGTCGCAT+AAGCTGAC
CCACCGTAACAAACTAGCACGACATGTCTAGAAAATTCGGATAAAGGCAAATCAGTAATACCTTGCCAAGCCAATCGAATTAACAAACAATTCGAAATAGTATTCAAAATGTCCGTAATTGGTGATCCAGAAGGAATACCGCATAGTACG
A00129:980:H5TVGDSX2:4:1169:13883:227481:N:0:TGTCGCAT+AAGCTGAC
TATATTTTTCTTTCTTACTCCAATTACTTTCTTCTACGGCAAATACAAGTTATTTCATTTCTTTGCGCTTTATAAGTAACCGTTGTAACTTAGTAACTCTTAGTTCGAGGAATTATTTAGAAAGCTTTTTAAGTAACAATATATTT

Hi @Vanessa_Corby-Harris
I cannot reproduce megablast error on usegalaxy.org. I tested several small query datasets.
‘>’ character should be visible on data preview. If it is absent, there is no proper name line.
Can you run any other tool on the input/query file, for example, convert FASTA to tabular? If yes, recreate the FASTA file using tabular-to-FASTA. Do you see ‘>’?
Kind regards,
Igor

Hi @igor,

Thank you for answering! I can convert my FASTA to tabular. If I take a file from my collection, the forward reads, I input something that looks like this:

and I get something like this:

I don’t know of a tabular-to-FASTA tool. Is it buried within something else? When I search for that, nothing comes up.

@igor

Hang on a minute… I might know what is going on.

@igor

I was using an old version of megaBLAST (circled in red). I am using the USDA SciNet Galaxy, and this is an option still.

I don’t see it on the usegalaxy.org (non-USDA SciNet) page. I guess they need to deprecate/retire/take down that option. But I still don’t know why it wouldn’t work correctly. Maybe something associated with that tool needs updating or whatever.

At any rate, thank you for taking time out for this.

V

Hi @Vanessa_Corby-Harris
maybe contact USDA SciNet Galaxy support team. It looks like a server/local issue.
Alternatively, copy the query file to a public Galaxy, do Blast search, and copy the results back.
The procedure:
on ‘source’ Galaxy click on name of FASTA file. Click at Copy Link (chain) icon.
activate Upload menu on ‘target’ Galaxy, switch to Paste/Fetch Data tab, paste the link and hit Start.
Hope that helps.
Kind regards,
Igor