No-mixed behaviour HISAT2


I am trying to adapt the HISAT2 options to my samples and I encountered this problem:

I know what I want: I don’t want HISAT2 to try and align individual mates.

So I should add the command --no mixed behaviour.

But what this means in Galaxy? Yes or No?

It basically says: HISAT2 does this. By default is False (no-mixed). Do you want for No-mixed behaviour to be disabled? Y/N.

It sounds like I am disabling the button that disables? Is Galaxy using the default settings for HISAT2 (and other programs)? Or it comes with its own recommendations?

I am not sure what Yes and No mean in this context. Am I reading too much into this?

1 Like

Then leave the option as the tool form default (set to “No”).

I agree this is a bit confusing … underlying tool defaults versus tool form defaults … but hope that helps!

1 Like

Right, so the underlying tool defaults would be what HISAT2 has on default. Tool form defaults would be Galaxy. So Galaxy adds --no-mixed command as a default. So at the question: Disable no-mixed behavior? the answer: NO, keep the command there.

Is this right?

I tried to google the terms and I couldn’t really find them.

Correct, keep the setting at No :slight_smile:

1 Like

Now that I looked into the Galaxy command line, in HISAT2 there is not the command no-mixed behavior

ln -s ‘naming_the_file_and_location’ genome.fa && hisat2-build -p {GALAXY_SLOTS:} genome.fa genome && ln -f -s ‘naming_the_file_and_location’ input_f.fastq.gz && ln -f -s ‘naming_the_file_and_location’ input_r.fastq.gz && hisat2 -p {GALAXY_SLOTS:} -x ‘genome’ -1 ‘input_f.fastq.gz’ -2 ‘input_r.fastq.gz’ --rna-strandness FR | samtools sort -l 0 -O bam
| samtools view -O bam -@ ${GALAXY_SLOTS:} -o ‘naming_the_file_and_location_of_the_final_file’

This happened with the button set NO (default).

1 Like

If the underlying tool has a default setting, and that is chosen on the tool form, then the command-line string doesn’t need to include it.

I agree, but I thought that that the tool form default it is not the same with the underlying tool default and that is added in the command line that Galaxy runs.

But apparently it is not like that.

In this case the underlying tool default and the tool form default are the same thing. So my premise was wrong. This means:

Right? Please correct me if I am wrong. :slight_smile:

Actually, I should have said as Plan C. Unless you change that, HISAT2 will look for:

  1. concordant alignment

-if it cannot find that:

2.discordant alignment (add --no-discordant to not look for that)

-if it cannot find that

3.individual mates (add --no-mixed to not look for that)

Assuming you add only --no-discordant, then will HISAT2 look for concordant and then, individual mates, skipping the discordant alignment? I think so but I don’t have facts (so far).

1 Like

Yes, that sounds correct.

Since you are trying to work out a command string for a direct HISAT2 job, outside of Galaxy, you might want to skip trying to interpret Galaxy command-line examples (are highly abstracted) and just review the HISAT2 manual plus check other general bioinformatics forums that focus on command-line usage.

I would also suggest just testing out what happens when you combine parameters in different ways. Sometimes that is the best approach to really understand how a tool combines/orders parameters.

1 Like