SortMeRNA have some problem with paired samples


We have occurred some problems when using the SortMeRNA with paired end samples. We suspect our RNA seq reads have ribosomal RNA contamination and try to filter them out. However, SortMeRNA reported an error (still green but the output file is 0kb) as shown below. We were wondering which part could be wrong. All parameters are default, and we tried the non-paired option which works perfectly, but the results cannot be used for further analysis like STAR.

Thank you so much for your time!

Hi @Pinhki

We discussed this over email but maybe this summary helps :slight_smile:

  1. The reference needs to be input to the tool (required). It was empty last time I checked, and the stderr in your screenshot has that same error message. Another error I reviewed included a reference but it was in the wrong format.
  2. does not have any references for this tool natively indexed at this time.
  3. For a successful run, you’ll need to provide a properly formatted reference yourself from the history, or consider using the tool at (has some indexes).

Thank you for your help and previous email!

However, this is another problem I met, and I indeed inputted the reference into the tool.

Actually, I downloaded all the references provided and upload them to the Galaxy. I have successfully run samples with the non-paired option, so I think the problem should be something about the paired function.

1 Like

Oh, sorry, I forgot that you asked about that. I’ll review.