substract overlapping intervals

Hi,
I’m trying to subtract the intervals of two datasets (operate on genomic intervals) and I’m getting the unchanged first dataset, although there are overlapping intervals (I’ve got plenty of them using Join the intervals of two datasets side-by-side). Any idea what I do wrong? i’m new in the field…

1 Like

Welcome @agata_s

Perhaps you have worked out the problems? I reviewed a few of your most recent jobs using this tool and the outputs are not identical to the first dataset. Meaning, entire rows were “subtracted” from each based on the second dataset’s intervals.

The tool has two modes – the form explains both, with links to even more descriptions and examples. It looks like you are using the first mode. I would suggest trying the second mode, even if just as a way to better understand how the two modes work.

Since your data is all based on a common model organism, there are expanded choices for viewing the results in a graphical format at public sites, or you can set up a local IGV (your choice). Expand the datasets to see all “display” choices. Load them all up (original inputs, different outputs resulting from different modes/settings). Then zoom into regions and you’ll get a clearer idea of exactly how the data is modified by the operations. You can rename datasets any way you want to make it easier to keep track of what each represents in the display.

Many of these tools are also included in the Galaxy Introduction Tutorials from the GTN. All Intro tutorials should work on usegalaxy.org, even if not specifically annotated with that server as being “appropriate”. The tool versions change over time and so may not be exact – but most of those changes were minor and you’ll be able to figure out what to do with a bit of experimentation.

Once you are ready for the more advanced tutorials, which server’s host the specific tools included will become more important to pay attention to (although, even for many of these, the tool version was updated in some minor way, and the tutorial will likely work).

If you get stuck again, let us know here for community help (new question = new topic) or you can communicate directly with the GTN trainers (including me and others that help here) at Gitter: https://gitter.im/Galaxy-Training-Network/Lobby. Each tutorial also has a feedback form. We review that cumulative feedback to learn which tutorials would benefit from an update or tune-up to make it easier to use or understand. And if you are interested, later on, community contributions for tutorial development is always welcomed (ongoing or during Co-fest events). https://galaxyproject.org/teach/gtn/

Thanks!

Hi
yes, I found a solution. I modified my input files (removed few columns) and it worked. It seems that this tool did not like some columns in the files that I’ve got from Encode.
Thanks a lot for your interest and advices!

1 Like