VCFfilter region - do not want to filter on region

I am trying to filter a VCF dataset of depth (DP), however I do not want to filter on region. If I leave this section blank the tool does not run when submitted. What do I need to put in the region filter to ignore this parameter please?


1 Like

Hi @KeeleyB

Region shouldn’t be required.

Do you mean that a gray dataset (queued) is created in the history or that the tool form itself doesn’t submit at all (nothing is added to the history)? The first might be expected at times, the second may indicate that the input VCF has some technical problem.

  1. Is the assigned datatype vcf for the input dataset?
  2. Did you assign the datatype directly or did Galaxy autodetect the datatype?
  3. What happens if you go to pencil > Edit attributes > Datatype tab and redetect the datatype? Is it still vcf?

If the input is in vcf format, where are you working (public server URL, or describe if other). Are you using the most current version of the tool? The top of the form should report this:

VCFfilter: filter VCF data in a variety of attributes (Galaxy Version 1.0.0_rc3+galaxy3)

Let’s start there, thanks! If you want to post back the header of your vcf dataset, that will help.

Thanks Jennifer,

It doesn’t even add to the history so maybe it’s a blip. I’ll tell my student to keep trying.

Thank you

DISCLAIMER: This email is intended solely for the addressee. It may contain private and confidential information. If you are not the intended addressee, please take no action based on it nor show a copy to anyone. In this case, please reply to this email to highlight the error. Opinions and information in this email that do not relate to the official business of Nottingham Trent University shall be understood as neither given nor endorsed by the University. Nottingham Trent University has taken steps to ensure that this email and any attachments are virus-free, but we do advise that the recipient should check that the email and its attachments are actually virus free. This is in keeping with good computing practice.

Hi @KeeleyB

Given the extra information – the job is not even submitting, correct? We made a change earlier today to fix a problem that is contributing to the odd behavior. It isn’t on the server yet but expect it in the next few days.

Meanwhile, this is the workaround:

  1. Load up the tool form
  2. Submit – this will abort and redirect to the top of the form
  3. Click into the blue box for “regions”, type anything, then remove it
  4. Submit – this one will actually launch the job

This gets around the problem. Several tools are impacted, and only at The problematic “free text” will always be highlighted in a light blue box, and may be nested in advanced settings. If you run into this again with another tool, and can’t find where the “blue box” is, post back with the full tool name and version and we can help.


Thanks for reporting the bug :beetle:!

Cross-posted in Matrix chat here: You're invited to talk on Matrix
and Gitter chat here: galaxyproject/Lobby - Gitter