velveth Galaxy error

Hello everyone,
could you help me please,
when I use velvet h in Galaxy it gives me error.

here is the instructions in galaxy tutorial:

  1. velveth tool with the following parameters
  • “Hash Length” to 29
  • “Input Files”: click on Insert Input Files
  • “file format” to fastq
  • “read type” to shortPaired reads
  • “Dataset” to the pairs output of FASTQ interlacerThe tool takes our reads and break them into k-mers.

and here is the galaxy I perform the instructions:
Hash Length: 29

Choose the input type: interleaved paired end

read type: short paired reads

Dataset: FASTQ interlacer pairs from data 2 and data 1

but when I execute it gives me error

Not sure if I can help but what is the error?

The process did not turn green and was red but someone helped me and now my problem is solved.
Thank you so much
I appreciate your attention

Good to hear, thanks for the follow up.

For the next time, you can click that red history block and see the error message. You will also see a “bug” icon and if you click that icon you get a more detailed error message.

Thanks again

Thanks a lot

Hello. How did you resolve this error? I am trying to work on the tutorial, but get stuck at this step since when I execute the velveth, it gives me the same error. Thank you for your help.


Someone kindly answered me and said: "Technically this tool is deprecated. That said, you can try adjusting the input datatype to be “fastq” instead of “fastqsanger” to avoid the specific reason your job failed.

The job may still fail even after changing the datatype: for format reasons (interleaved may be problematic) or for resource reasons (different errors – likely reported as an out-of-memory error). But the above is worth testing out."
I was using at the time, and it worked for me when I tried fastq instead of fastqsanger.

1 Like