VGP busco troubleshooting

Hello,

I am running VGP workflow on Galaxy but everytime i perform VGP HIFI phased assembly or VGP hybrid scaffolding, i end up with problem in busco "Fatal error: Exit code 1 () " or it get stuck with no or corrupted results. Everything else seems workig fine in the workflow

Any advice how to solve it ?

Regards

1 Like

Update

I’m guessing that you are running the workflow associated with this tutorial, or just following along manually. VGP assembly pipeline - short versionhttps://training.galaxyproject.org/training-material/topics/assembly/tutorials/vgp_workflow_training/workflows/main_workflow.ga

Please try running through it at UseGalaxy.eu or UseGalaxy.org.eu for now. We should have it functional at UseGalaxy.org within the next week or two. BUSCO in particular has problems we are currently troubleshooting.

I’m going to mark this as the “solution” so others will find it, but won’t close it out until fully resolved.

Thanks for reporting the problem! :slight_smile:



Hi @HT87

Are you working at UseGalaxy.org? Did you try opening and saving the workflow in the editor before executing it? This will trap any warnings and correct metadata that is server specific.

I think I found your bug report. But if that was not yours, please also send in a bug report from one of the error datasets. Leave all datasets/jobs in that history undeleted please. Ideally, that history would only include your raw input datasets, any pre-processing steps, and then the jobs the workflow invoked (any state).

The VGP workflow is still under final development, but we can still troubleshoot now.

  1. Please post back the original URL for the workflow (what was pasted into Galaxy for the import).
  2. Also please post back a link to where that workflow was sourced for context.
  3. Then to close the loop, generate a share link to the workflow you used (the version loaded into your account) and also post that back here.

Let’s start there, thanks!

Hello @jennj

Thank you for prompt response. I tried to run it on usegalaxy.org after saving the workflow in editor before executing and it gave the same result with busco getting stuck.
I will try running it on usegalaxy.eu based on the recent instructions and update you if the issue is resolved.

Regards,

1 Like

Hello @jennj

VGP workflow was successful when i moved to usegalaxy.eu, busco went fine.

Thank you

1 Like