bowtie2 not working

hi all, I’m trying to align some fasta using bowtie2 but I get the error:
tool error

An error occurred with this dataset:

Unable to finish job
any help is appreciated!

1 Like

Hi @nibhelim

That’s not enough information to tell what is going wrong, but most errors are due to input format problems. So I would suggest checking those first to see if it clears up the problem.

FAQ: * My job ended with an error. What can I do?

You might also just want to rerun first. At least one rerun is recommended for failures (to eliminate transient cluster issues). Plus, we just updated the Galaxy Main server and that has had a few problems, mostly resolved now, and your prior job might have been impacted.

Let us know how that goes and we can follow up from there if needed.


hi, thanks for the help @jennaj! the thing is that there are no indications on the nature of the error, just unable to finish the job and the error detail is empty. I tried to rerun the analysis but still the same error.
any tricks?

1 Like

I’m getting the exact same error when aligning with both STAR and HISAT2. Any help or updates on what’s happening would be appreciated!

1 Like

@nibhelim & @Priscilla607

You are both working at, correct?

Please send in a bug report from the problematic mapping jobs (just one each is enough). Include a link to this Galaxy Help post and your “@” here in the bug report comments, so we can track everything together.

There may be some type of cluster issue – this will help to clarify if that is the problem, or if there is some other server-side issue. If the problem is data/inputs/parameters, we can work on that directly via email privately.


@nibhelim & @Priscilla607

Update: We’re having a few problems with bug report submissions. That should be resolved soon (possibly later tonight/early tomorrow). It wouldn’t be easily noticeable as a problem from your side – so I wanted to let you know in case you sent something in and were not sure about the status. Right now, we don’t have a bug report from either of you to work with and there isn’t a way to get it sent in, yet.

I’ll post back once this functionality is intact again. Then, please resend whatever error you sent in before. Please be sure to include the originally requested information in the comments so I can find those.

We just updated the server and if there is some reproducible server issue with mapping jobs, that is definitely a priority concern, and you both would be helping us out by sharing examples. My guess is that the problem is isolated to a certain set of conditions, meaning == not all mapping jobs, but your bug reports will help to determine what is going wrong along with other tests I’ll do.

And if it turns out to be data/inputs, can help with that, too. Either way, we’ll get this resolved.

Thanks! :slight_smile:


I’ve been getting the same error message with Bowtie2 and BWA-MEM since yesterday. I ran mapping stats with Bowtie2 and I am getting a high alignment percentage for most of my fastqs (>90%) and a .bam file is created but it says it is unable to finish the job and I noticed it cannot create a .bai file.

Any help would be much appreciated! Please let me know if I can share my history with you somehow.

Thank you!

1 Like

I am getting the same EXACT issuues as @Athina has mentioned. My alignment percentage is like ~98% but I get the same error message. I’ve tried using different parameters for both BWA and Bowtie for days and still get the same error.

1 Like

@Athina @Jamal_Williams @Priscilla607 @nibhelim

Thanks all for writing in about the problem. Direct bug reporting from the web interface at is still problematic. More updates soon about that.

Let’s try another way. Send a direct message to me (@jennaj) with:

  1. A share link to the history that contains the problematic BAM result(s). Be sure to check the box for sharing “objects” in the history. Unshare/reshare the link if you are not sure if this box was checked. The function for “Share or Publish” is listed in the history menu.
  2. Dataset number(s) for the BAM results
  3. Please do not delete the BAM results or any of the inputs used to create it from your history

Direct messages (sent, received, etc) can be found here in the Galaxy Help web interface:


As a short-cut to send a new direct message, click on the “@” for the person you want to send to. An “envelope” icon will be in the pop-up. Clicking on the envelope will initiate a direct message.

There is likely either a server-side issue, the BAMs are too large to index, or some combination of the two. A few examples will help to clarify. We just updated the server – fixing any issues is a priority.

@jennaj Thank you for you reply. I now noticed that every time I logout and in again, the first run of Bowtie2 works fine, then the second crushes. For the same dataset. I am now trying to share everything with you as you suggested above.

1 Like

If this problem gets resolved can you let me know here, I got frustrated and deleted everything before I read @jennaj last post. Thanks!

1 Like

@Jamal_Williams Definitely will post back the results, however it turns out. But need an example first, as I haven’t been able to reproduce it on my own.

@Athina Interesting pattern, I didn’t try that. Also, I don’t see a direct message from you yet but will keep eye out for it :slight_smile:

@jennaj This is going to sound a bit ridiculous I am sure but I am unable to find the sharing “objects” box and how to actually create a link for you. Could you please help me with that too? Thanks!

@Jamal_Williams By the way I just wanted to say that Bowtie2 has now started working fine for me. Just this morning I checked again. Five consecutive runs of Bowtie2 and it is good. Not sure what changed.

@Athina Thanks for letting me know! I will try again today.

@Jamal_Williams Sounds like the problem resolved itself. Good! We updated the server last week and had a bit of trouble initially but most of that has been sorted out. Reporting bugs directly via the web interface is still problematic but is on our priority to-do list.

@Athina For future reference, to share a history, look under the History menu (gear icon) for the option “Share or Publish”. That option is also available for Workflows (in the pull-down menu, per workflow).

The interface has changed a bit since this FAQ and the video were created but it has the basics correct. It is on my list to update that – am waiting for the final round of UI changes to stabilize first.

What is new is the presence of an option when sharing histories to check whether to “share the objects” included in history or not (meaning: grant access to the datasets themselves so they can be reviewed/downloaded). In most cases, including for troubleshooting reasons and in publications/blogs/etc, you’ll want to check that box – unless you really just want to just share the analysis but not the actual data for some reason.

Screenshot: Objects set to be shared before clicking on the button to generate the history share link. If you can’t remember if you checked the box or not, just unshare, check the settings, adjust as wanted, and regenerate the link.


Update: Ticket for the issue is now here

In short, until resolved (when the ticket closes out), set the destination cluster on the tool form as described in the ticket and the linked workaround Galaxy Help post: HISAT2 Not working

I never received an example Bowtie2 error but was able to reproduce the issue in directed testing. The last round of the testing is in a shared history link in the Github ticket if interested.

Mapping jobs will route to available cluster resources. My guess is that initially for both of you that the jobs were routed to one cluster, then later on the other. One works, the other does not at present. This will be a priority correction.

@jennaj Thanks I just read your last post. prior to this I just ran Bowtie2 again today and I have the same issues. This is the link to my current example history:

@jennaj Hi, I used the solution you suggested and first time it worked fine, second time I got this error:
“Failed to write job script ‘/galaxy-repl/main/jobdir/025/126/25126033/’, could not verify job script integrity”

@Athina The second run is a transient cluster error. Rerun that one.

Glad other(s) worked!