BWA-MEM Index can't be found -- Resolved

I’m using a usegalaxy.org instance to analyze illumina data (paired end, trimmomatic trimmed) to a reference fungal genome (one I downloaded from Ensembl). I am using BWA-MEM in paired-end mode, but I think that it is failing in the indexing.

Every time I run it, I get this error:

[E::idx_find_and_load] Could not retrieve index file for ‘/galaxy-repl/main/files/042/990/dataset_42990690.dat’
[E::idx_find_and_load] Could not retrieve index file for ‘/galaxy-repl/main/files/042/990/dataset_42990690.dat’

Anyone have any suggestions?

2 Likes

Hi Rachel, are your datasets green ? This message is emitted by pysam before we index the bam file. If it is green there is nothing to worry about.

Thanks for the quick reply! The job is red indicating a failure. And this is the last thing it says before it fails. I was able to run the fastq files and genome through bwa mem using the standalone programs on the same files though. I ended up using the command line software to generate my bam files and moved those back to Galaxy for the rest of the analysis. Still no idea why it failed on the BWA-MEM step, but I was able to work around.

1 Like

Could you send a bug report for the dataset that failed ? You can do that with the little bug icon that says “view or report this error”

1 Like

Hi @Rachel

We’ve uncovered the root cause for the error. It was a server-side issue that will be corrected when this change is incorporated (within a few days) https://github.com/galaxyproject/pulsar/pull/230

Update 1 fix pending as of 9/2/20, see post below for a workaround.

Update 2 9/15/20: dedicated ticket for BWA + BWA-MEM issues https://github.com/galaxyproject/usegalaxy-playbook/issues/307

Thanks for sending in the bug report – very helpful!

Thanks for the update!

1 Like

I believe I am still experiencing this problem (BWA-MEM terminates in red error state and does not create a BAM index) on the public Galaxy site.

1 Like

Hi @Geoffrey_Smith

Thanks for sending in the bug report. Yes, your job appears to related. There were other changes made at usegalaxy.org, but the full resolution is not implemented yet.

Known impacted tools are: Stringtie, BWA, and BWA-MEM

Meanwhile, you can try directing jobs to the alternative cluster as described here: Error running Cufflinks

cc @nate

This was fixed as of September 22, sorry for not updating here. Please let us know if you’re still encountering issues.

1 Like