cannot add tools in local Galaxy

I installed the local Galaxy in Ubuntu subsystem in my Windows 10 computer. I used “nano galaxy.yml” to enter galaxy yml file and added my email after “admin_users:” After saving and quitting, I restarted Galaxy with “sh”. Then I went to http://localhost:8080 and was directed to a Galaxy page. I then registered with the email I added as admin_users and logged in. I clicked the “Installing Tools” and was directed to . In the link, I clicked the “Tool Shed” link of and then was directed to “The main Galaxy ToolShed serves” in the link of

Here, a lot of tools showed up. I randomly searched several tools and tried to add into my local Galaxy. But, the following page showed up and I did not know how to install to my local Galaxy. It is different from what is descripted in There are two points I need to point out. 1. Should I log in the Galaxy Tool Shed page? I tried with my admin email and password, but it failed to let me log in. 2. I also install a local Galaxy in anther computer (also Ubuntu subsystem in Windows 10) and added the same email to “admin_users:”. Does this matter? I have quitted local Galaxy from the computer when I used the my current using computer.

  1. You need to login with your account that is registered as admin.

  2. In de menu bar on top of the page you will see the button “Admin”. Click on this button to open the admin page.

  3. On the admin page you will see the admin menu on the left side of the page. From this menu open the “Install and Uninstall” page

  4. From here you can search and install tools

Thank you very much!
But, I did not see “Admin” button on the page though I know it supposed to be there.