Cannot open "display with IGV local D. melanogaster (dm3)" for the tutorial Reference-based RNAseq data analysis (long)

Hello,

I’m going through the following tutorial on usegalaxy.org. I got stuck at the point where I should click D. melanogaster link to see mapped reads on IGV after Mapping with TopHat2.

When I try it on Chrome, it suddenly closes the window that opens in milliseconds.

When I try it on Firefox, it asks me to “save/open with” a file (igv.jnlp) 2.0KB.

I cannot get the view of the reads that are mapped on the genome as shown in the tutorial. What am I supposed to do?

Thank you

Welcome, @ysrbrs!

Have you used IGV before in your current machine?

Check Chrome downloads; you may have the *jnlp file automatically downloaded in chrome, that’s why it closes quickly; but Firefox first asks what to do with it;

The *.jnlp file is opened by IGV (JWS, Java Web Start); e.g. IGV 2.3 | Integrative Genomics Viewer :

(1) Java Web Start (JWS). Use the buttons below to launch IGV directly from our web site.

  • Clicking on one of the buttons will download a .jnlp file and then execute the file using Java Web Start (JWS).

  • Some web browsers will only download the .jnlp file and not automatically launch IGV. For these browsers, locate the file in your folder designated for browser downloads, and double-click on the file to launch IGV.

You’ll find more info in the IGV User Guide | Integrative Genomics Viewer

2 Likes

Wow, many thanks for the swift reply. I wasn’t expecting this! Great!

I have tried to open the downloaded file on IGV on my PC but I get the following message:

“Error loading C:\Users\Administrator\Downloads\igv.jnlp: An error occurred while accessing: C:\Users\Administrator\Downloads\igv.jnlp Could not determine file type. Does file have proper extension?”

Any idea what might have caused this?

The extension is ok.
Can you launch IGV alone without problems?
Also, can you please confirm what OS version you’re using? Maybe it is not associated with Java (see this)

Check these solutions too

2 Likes

You’ve been extremely helpful! Thank you very much for responding on very short notice! It works now.

2 Likes

You’re welcome :+1:

@ysrbrs,

Can you please tell us which solution from

worked for you, just in case someone else experiences the same?

1 Like

Sure! The first one; associating with Java, I assume. I had to download Java and change it in a way that JNLP files are opened, by default, with Java Web Start.

I had in fact earlier used IGV but was not aware that I did not have Java because everything worked fine. I probably had some other files that did not require Java.

The link you provided explains it very clearly. It should be helpful for those who are, like me, not very strong with computational details.

1 Like

This will help. Thanks for sharing.

1 Like