Local IGV with Galaxy doesn't work

I am currently working on the tutorial Making sense of a newly assembled genome on Galaxy Training


and I have reached the stage of using IGV.
I am working on a Galaxy instance installed on my personal computer. After installing IGV on my computer, I start the visualization via Galaxy. However, an error appears:

There was a conflict when trying to complete your request.
Error generating display_link: A data display parameter is in the error state: fai_file”

So I tried the manipulation via usegalaxy and the error does not appear. It seems to me that the problem comes from my instance.

The file I use is a fasta file with 4 sequences (the same as the tutorial).

Do you have any idea what the problem is?

Thank you in advance for your answers.

1 Like

Hi @antoine_r

Please check the following:

  • The fasta dataset you are trying to load is from an intact fasta dataset. Meaning, the upstream manipulations were done correctly and successfully.
  • The datatype “fasta” is assigned to the dataset.
  • IGV is started up before clicking on the “IGV local” link.

If this worked at Galaxy Main https://usegalaxy.org, you could generate a share link the fasta dataset on the server and paste that into the Upload tool on your local Galaxy. Then test IGV again using it (from your local). If that data displays, it would indicate there is some problem with the version of the data created locally that you can investigate. There are several steps in this tutorial to prep the data and simple mistakes (by accident) should be ruled out before looking at potential software issues. You could also test on one of the smaller fasta datasets (after “Sed” but before the “Concatenate” step).

If you still have problems after this, then the problem might be with your local Galaxy install. I’m not aware of any global issues with “Galaxy > IGV” connections in a default local install using the most current release 19.01 (and would expect a different error if there was). If not using that release now, please try upgrading Galaxy to see if that resolves the problem:

If the problem persists using Galaxy release 19.01 and the fasta that worked on the Main server, please write back and we can troubleshoot more.



I just tested Galaxy > IGV local in a newly checked out 19.01 local Galaxy using all defaults and a very small fasta dataset (few hundred lines). The dataset loaded as a new genome correctly, so the problem is not with Galaxy itself.

My guess is that the dataset is too large to process in your local Galaxy. Sending fasta data to IGV involves creating a fasta index the first time the link is clicked on. Yours probably failed.

When successful, you’ll see something like this opened as a new tab in the browser where you have the local Galaxy open – but only the first time a dataset has the “IGV local” link used.


Subsequent clicks for the same dataset will not create an index again but use the existing index, which could be in an error state (job ran out of memory, formatting problem, etc).

You could try deleting the prior attempt from IGV (“remove genome”), copying the dataset back to your history, then trying again. This will reset the index creation. If it fails again, then your local would need more administrative configuration to handle the data (assuming those resources are available wherever you installed the local Galaxy server). This would probably including upgrading the database as the first step if you haven’t done that yet. See: https://galaxyproject.org/admin/get-galaxy/#configure-for-production

Other options include using public Galaxy servers, your own cloud Galaxy server with sufficient resources, and the like. See: https://galaxyproject.org/use/

Hi @jennaj

Thank you for your answer.

I tried IGV with a smaller file (the E. coli C fasta file used at the beginning of the tutorial, with Galaxy 19.01), but the problem persists.
When I use local IGV, I have this window that appears (regardless of the data to view):

But shortly after that I get this window:

However, I hadn’t noticed that I had an error message in my Galaxy history:


So I searched in my directories, but the 934 folder doesn’t exist:

This problem makes me even more confused.

1 Like


You are missing dependencies that Galaxy needs.

I can reproduce this in a Galaxy release version 19.01 that was initialized/started up without using a Python virtualenv (a Conda virtualenv was used, because I have conda installed on my computer, and you probably do, too). The beginning of the startup log when you first initialized Galaxy notes if a Python versus Conda venv is used.

Other things could potentially go wrong when using Galaxy this way. There is probably some method to fix all the potentially missing dependencies but this would require but I don’t know the scope for this release and the developers always state to just start over using Python.

Please see this Q&A from yesterday that covers how to make the correction: Error when trying to run Galaxy on MacOs

It is important to note that this is only a first step – my test involved loading up a fairly small fasta file (successfully), launching IGV, and then clicking on the “IGV local” link. Same exact error as you report (from IGV). Larger fasta files (over ~150 MB) also failed but with a different reason, even though I was testing in a Conda venv build Galaxy. So, the data in the tutorial might still be too large for your local Galaxy (with default configuration under Conda venv) but you can test that out. This would be the starting place for recreating the error data (the error dataset you show might resolve – it looks to be due to a missing dependency) and also going further with more administrative customization should you decide to go that route.