Dataset collection not recognized as possible input


I am trying to run Trim Galore! on my set of dataset pairs and I have previously created a dataset collection of forward and reverse reads. They are also in the fastqsanger data format. However, Trim galore does not seem to recognise this, nor does HISAT2 for the matter. How can I fix this?


can you please double check the datatype assigned to the files? Click at collection, click at any sample, click at forward file. What datatype do you see in format filed? Is it fastq or fastq.gz? By any chance, is it fastqCSsanger? Trim Galore does not see files with fastq(.*) datatypes. This issue is discussed on the forum multiple times. Current version of Galaxy does a good job in assignment of proper datatypes during upload.

If the data has one of fastqsanger(.*) datatypes, maybe share the history and post the link here.

Kind regards,


Hi Igor,

Here is the link to the history:

The data is in the format fastqsanger. I’m not sure about fastqcssanger or the other types of datatypes as it is my first time using it. I also have a problem with running the data through trim galore! and HISAT2 which returned negative outputs so I am really wondering if the raw data is corrupted or in the wrong data format.



Hi Wayne,
I cannot access the data. This is not a public Galaxy server. It is for ‘internal use only’.
Maybe consider testing the tool on datasets, not a collection. Unhide files for one sample and check if tools can access the data.
Alternatively, test one or two samples on any public Galaxy server, such as or Upload the data and let the Galaxy pick up the datatype.
The third option: contact the local support.
Kind regards,

1 Like