Docker build of Galaxy, ToolShed tools don't show up but are installed

Hello all,

I am attempting to create a docker image for a “flavor” of galaxy for one of my colleagues. Just to test things out, I’ve tried building from the bgruening/galaxy-stable image, and I’m only adding one tool from the tool shed: peptideshaker.

The image builds without issue, and even launches, but the peptideshaker tools do not appear in the sidebar of the galaxy page exposed at port 8080.

Here is my docker file:

FROM bgruening/galaxy-stable:latest

MAINTAINER Björn A. Grüning,


WORKDIR /galaxy-central

RUN add-tool-shed --url '' --name 'Test Tool Shed'

# Install tools
ADD my_test_list.yml $GALAXY_ROOT/tools.yaml
RUN install-tools $GALAXY_ROOT/tools.yaml

# Mark folders as imported from the host.
VOLUME ["/export/", "/data/", "/var/lib/docker"]

# Expose port 80 (webserver), 21 (FTP server), 8800 (Proxy)
EXPOSE :8800

# Autostart script that is invoked during container start
CMD ["/usr/bin/startup"]

and the file my_test_list.yml:

api_key: admin
galaxy_instance: http://localhost:8080

- name: peptideshaker
  owner: galaxyp
  tool_panel_section_label: "PeptideShaker"
    - 3ec27b4cee7c

When I check to see if the peptideshaker tool is installed (as an admin), the tools are installed. However, I can’t see them in the sidebar, nor can I see the “PeptideShaker” section that was meant to be created, and the tools do not show up in the search in the sidebar.

I’m sure others have run into this issue. Does anyone know how to resolve it?

Thanks in advance!

Hi @pjlombardo

Your server seems to be not be picking up the new config, or the new tool panel section at all, and I’m not sure why. It looks like you are follow this exactly: GitHub - bgruening/docker-galaxy-stable: 🐳📊📚 Docker Images tracking the stable Galaxy releases.

Let’s ask at the chat for the Docker Image. They may reply here or there, and feel free to join the chat. You're invited to talk on Matrix

Hi @jennaj,

Yes I tried to follow that exactly, but something didn’t work I guess. I checked the chat, but no one seemed to respond. Have you had any further thoughts on this?

If not, I suppose I can just add the tools manually each time we update or make serious changes on the server.

Hi @pjlombardo … sorry to hear that didn’t work at the chat.

The Docker image is being redone, so this might be one of the known issues with it. To complicate it, the way the tool bar is populated also changed.

These are the files to examine. Maybe checking those helps to isolate the problem? Galaxy Configuration — Galaxy Project 23.1.1.dev0 documentation