Editing Workflow WIth Screen Reader


I am a new Galaxy user. I am blind and navigate the web using screen reading software (specifically VoiceOver on a Mac). I’ve found the site to be quite accessible so far.

One feature that I’m having trouble navigating is editing workflows. I’m taking the Hopkins course (useGalaxy101, module 2). I’ve created a workflow but have trouble navigating the default display and finding how to change the names of the input and output files.

I was hoping to find an alternative way to do this that could be more text-based and easier to navigate, but I haven’t found anything on my own.

I’ve tried with Safari and Chrome.

Can anyone suggest other things to try?



Hi Liz,

I don’t have an accessible text-based alternative to suggest to you, but I would definitely like to follow up on what we can do to make this interface more navigable. I will set up and try VoiceOver and see what that experience is like.

In the meanwhile, it’d help me if you could describe in more detail how you’d usually expect to be able to do this sort of thing – is it primarily the structure of the page that makes this difficult? Are there any obvious accessibility features we’re neglecting here?

Sorry you’re having trouble with the workflow editor! I’m sure we can iterate on this and make it a better experience.

Thanks for using Galaxy!



Hi Dannon,

Thanks so much for your quick response!

I’m working through the Hopkins course on using Galaxy on Coursera. I’m attaching the transcript of the video instructions, which differ slightly from the Galaxy 101 tutorial on the galaxy web site.

To give you an idea of my experience using it, I get as far as the Galaxy Workflow Editor (Mac Safari)

VoiceOver command ctrl-option-f to find text on screen, enter name of workflow to get to the section of the page with the workflow displayed

VoiceOverCommand ctrl-option right arrow to go the next page element identified by Voice Over

VoiceOver tells me that my workflow name is a “group”

VoiceOver command ctrl-shift-option-down arrow to enter the group

An error beep tells me I can’t do that.

VoiceOver command ctrl-option-right arrow to go the next item VoiceOver identifies

It reads me the filename for the first file in the workflow.

Another ctrl-option-right arrow says “output”

Another ctrl-option-right arrow tells me “output” is a group, but again, when I try to enter the group (ctrl-shift-option down arrow) I get the error beep

Voiceover command ctrl-option-right arrow for the next item gives me the name of the second dataset in the workflow.

Then there is another bit of text that says “output” and behaves the same way as the previous one.

The point of the exercise is to rename these so they can be used with different data sets. I’ve gone back to the tile names and the “output” text elements and tried to interact with them (ctrl-shift-option down arrow) to edit them but have not been able to do so.

Going through the rest of the page doesn’t show me anything else that looks like a way to edit.

I hope this helps you to understand what i’m trying to access.



(Attachment galaxyWorkflow.txt is missing)


Hi again,

The attachment of the instructions was rejected. Please let me know if it would be helpful to you and if there’s another way to get it to you.



1 Like

If you would like to attach the instructions, it might be easiest to paste them into gist.github.com or a similar service and include the link, though I think I have a good feeling for at least a few problems based on what you’ve outlined above. This is super useful, thank you very much!

1 Like

Thank you for reading it all!


1 Like

I created an issue to track our progress on this here, to make sure this doesn’t fall through the cracks: https://github.com/galaxyproject/galaxy/issues/7701

Thanks again for all the information, I’m going to try to finish this up and get a bugfix out for this in the next week or so.

1 Like

Hi Dannon,

Thank you so much for following through with this!

As I continue learning about Galaxy, I’m finding other screen reader access issues. What’s the best way to report these? Should I add them on to this thread or start new ones for each? Is this forum the best place?

Thanks again,


1 Like

This forum is a good spot to let us know about the issues. I think continuing the thread would be fine.

If you prefer github you can also add them to the issue that dannon created and linked above.

Thank you very much for providing us with this super valuable feedback!

1 Like

Another issue I found is with uploading data from my computer.

With VoiceOver on, I

Ctrl + Option + Space to activate “Get Data”

Ctrl + Option + right arrow to “upload file from your computer”

Ctrl + Option + Space to activate “upload file from y our computer”

Ctrl + Option + right arrow repeatedly to move through the items

I get a list of places to get data, like “UCSC Main Table Browser,”, "UCSC ArArchaea Table Browser, " “EBI SRA”…
and then I get back to unrelated options like “General Text Tools,” “Text Manipulation…” If I keep going I get all the way to my history section without any controls that would let me upload a file.

Please let me know if you have any questions.


1 Like

I just tested this and you are absolutely right. The ‘upload file from your computer’ is opening a modal window but we never put focus to it. So you are browsing the page ‘behind’ the window. We will fix this!

Update: we have included a fix and it will be part of the 19.05 release that will go out in a few weeks. It will get on usegalaxy.org in next few days.



Thank you so much! I especially appreciate that you explained what was going on with the modal because this happens on many websites.



Hi Liz,

I hope everything is well. I have set up the screen reader on mac and have been working on making the workflow editor more screen reader friendly. I have made some significant improvements that I will commit soon. Additionally, I have been making improvements to the entire galaxy application to make it 100% screen reader friendly. This is now the main project I am working on and I will not stop until galaxy is 100% usable with screen readers. I may need your help testing this out once it’s complete. You can expect to hear updates soon.

Best Regards,
Will Holden


First pull request made here: https://github.com/galaxyproject/galaxy/pull/8334.

I am currently working on another branch with more improvements for screen readers.

1 Like

Here is the second pull request which will eventually be a pull request into the galaxy dev branch https://github.com/WilliamHolden/galaxy/pull/1

This pull request makes the workflow editor 100% screen reader friendly. There are a few minor issues as working with screen readers can be a little tricky sometimes, but it works well for the most part. I’m still working on refactoring some of the code and then we will need to do quite a bit of testing to make sure it works as intended.

I will continue to post updates here.

Thank you so much for all your work on this! I’m just getting back into my coursework on this and it’s very helpful.


Linked Q&A that also addresses accessibility: Non-visual Galaxy documentation?