ERROR: No such file or directory when I am using SRR number from NCBI

Hi, I am trying to use the Fastq Dump Paired Downloader, to get my forward and reverse sequences using the SRR number from NCBI. But there are some SRR that gave me this error: "no such file or directory. How can I fix it?

Hi @emvquinones

Any extra spaces or tabs or blank lines in the query can lead to this problem.

Try getting the data again. Make sure that only the query accession(s) are in the input with no whitespace – whether on the form (single accession) or in a list (multiple accessions).

If you have an accession that persistently fails, double check the accession is valid for fastq read data using the search at the top of this webpage, using all defaults: If an accession is valid, but the Galaxy query fails, the NCBI service may have been busy and you can try again. We’ll need that example accession to help more.


Yes all the accesions number I could find them in the NCBI. The problem is when I’m trying to retreived them, it goes on an on with the error. I am trying since last week. I tried to contact NCBI but they said that issue they can’t help me and that I need to contact Galaxy Trakr for the help. Here is one of the accesion number for example “SRR21481169”

1 Like

Hi @emvquinones

OK, I agree – this is an issue for the administrators of that server. Those admins do not follow this forum but do have an email contact. See the directory listing here: GalaxyTrakr - Galaxy Community Hub. I can confirm that the tool you are using fails. I tried to submit a bug report but that function doesn’t appear to be available at the server.

Accession reference at NCBI (to confirm these data are paired): run_browser&acc=SRR21481169&display=metadata

You could also try using a different tool. Two alternatives are in this shared history:

Hope that helps :rocket: