Error with heatmap2 analysis

Hello everyone,

I’m following this tutorial for my RNA-seq analysis : Reference-based RNA-Seq data analysis (Reference-based RNA-Seq data analysis)
and Im trying to generate a heatmap plot for Z-scores.

I already generated a heatmap for Normalized counts for the most differentially expressed genes , according to the tutorial.

And then the next step is to acquire a heatmap plot for Z-scores for the most differentially expressed genes. In this step, I get this error:

This job was terminated because it used more memory than it was allocated.
Please click the bug icon to report this problem if you need help.

According to the tutorial I should do the following steps:

However when I go to the heatmap2 tool :

  1. Compute z-scores prior to clustering” doesnt exist
  2. as input the tutotial has : Normalized counts for the most differentially expressed genes , I suppose that this is an error of the tutorial right? Cause as input I guess that I should put the Z scores that have generated
    (In any case I tried both as input the Z scores or Normalized counts for the most differentially expressed genes and I still get the same error)

What I put as input:

Aany help will be much appreciated :pray:

Hi @dimitris

The tutorial should be working exactly correct if you are working at one of the servers listed under “Available at these Galaxies” (at the top of the tutorial).

The Z-scores are calculated at runtime, so do use the count input specified. Once you have that working you can explore the data any other way that you want of course.

The error message about running out of memory means that there is either some runaway job (usually an input problem) or that the work is actually too large to compute at the public services. The first is much more common, and the latter can happen but not with a tutorial’s small data.

Now, some tutorials were designed to work with specific versions of tools – so if the form doesn’t match up by default, it can still usually be found and used. Changing the tool version

And, since you have all the data loaded already, you could try loading up the tutorial’s workflow, then running it. Send the results to a new history. That can become a reference when working through this manually and helps to find problems.

If none of that solves your error or you get a new error that you can’t figure out, would you please generate and post back a link to your history? Sharing your History

Hey again,

I still didn’t manage to solve this issue.
This is what the workflow suggest for generating a heatmap plot for Z scores:

However when I go to heatmap2 I get this ( probably cause Im working from which is slightly different from

If I press at the Data scaling → scale my data by row, will this calculate the Z score ?

Thank you a lot in advance

Hi @dimitris

Hopefully you discovered this already … but the scaling is a graphing function.

If the version of the tool you are using does not compute z-scores (and that older wrapper version didn’t), then you can try using an updated version of the tool wrapper at a different server or probably better, the admins of the server where you are working could update the tool? If you want to use it, others probably do too.

1 Like