Error with new tool ChewBBACA

Hi there,

I am trying to use the new tool ChewBBACA. I am unable to use the majority of functions. I have tried creating my own schema and using an external schema and seem to always get the following error

Traceback (most recent call last):
File “/usr/local/tools/_conda/envs/mulled-v1-5528b78b7946700faeea31529d0d622524f44427ecb466a557fe05be5640acd6/bin/”, line 6, in
from CHEWBBACA.chewBBACA import main
File “/usr/local/tools/_conda/envs/mulled-v1-5528b78b7946700faeea31529d0d622524f44427ecb466a557fe05be5640acd6/lib/python3.10/site-packages/CHEWBBACA/”, line 21, in
from init import version
ImportError: cannot import name ‘version’ from ‘init’ (/opt/galaxy/server/lib/galaxy/jobs/rules/

Is this something i’m doing wrong ?


Hello Jesse,

Thanks for the report. The problem is solved now. please try again.


1 Like

Hi Amirhossein,

Thank you for solving this issue. However i am now getting the following errors;

Could not get input files. Please provide a directory with FASTA files or a file with the list of full paths to the FASTA files and ensure that filenames end with one of the following extensions: [‘.fasta’, ‘.fna’, ‘.ffn’, ‘.fa’, ‘.fas’].


Hi @jessemartin

Would you please share a bit more about what you are doing? Screenshots or shared history will work for this, see the banner at this forum for how-to, or see How to get faster help with your question

The message you are getting is directly from the underlying tool. For use in Galaxy, you would input datasets with the datatype fasta assigned.

Screen Shot 2024-04-19 at 9.52.03 AM

Some general data tips:

  1. Upload data → Getting Data into Galaxy
  2. Data in fasta format will have that datatype autodetected correctly.
  3. If you are using a collection folder of datasets, click on the folder icon to tell Galaxy to look for a folder. :slight_smile:
  4. Input datasets need to be in the active history. Try refreshing the browser window to see which history you are working in.

Hope this helps but you can explain more if not solved yet.

Hi Jenna,

I’m initially trying to create a schema using 9 genome assemblies with the goal of ultimately using this schema to determine cgMLST’s . The assemblies are definitely in fasta. I Have tried by selecting multiple individual datasets and also as a collection.

I Would be more than happy to share my History if this would help?


Hi @jessemartin

I’m curious about the error you are getting now. Is it still the same? And you are working at

You can share a history, or post out those details, or both :slight_smile:

Hi @jennaj

I haven’t tried again today but I will now. Yes definitely working as

Please let me know if you need any more information.


Hi @jessemartin,
It seems that there is a problem with the input file(maybe with the upload). Could you please report the issue and also share your history?


Hi @nilchia
The fasta files were produced using medaka and not uploaded, could this be an issue? I have reported the issue and below is the history


Thanks. I have replied to your report. Please let me know if the problem is resolved.