Example step-by-step for a basic local Galaxy install with an admin account created


I am just getting started with developing Galaxy.

I cloned the repository onto my local computer - MacOS running High Sierra 10.13.6.

Next, I created a virtual environment, activated it, and then tried the run.sh script.

A lot of things were downloaded and installed, but then the script died with this error:

Requirement already satisfied: setuptools in ./.venv/lib/python2.7/site-packages (from sphinx==1.7.2->-r ./lib/galaxy/dependencies/dev-requirements.txt (line 32)) (41.0.1)
Activating virtualenv at .venv
galaxy.tools.deps DEBUG 2019-05-30 17:32:26,193 Unable to find config file './dependency_resolvers_conf.xml'
executing: .venv/bin/uwsgi --module 'galaxy.webapps.galaxy.buildapp:uwsgi_app()' --virtualenv /Users/aloraine/galaxy/.venv --pythonpath lib --threads 4 --buffer-size 16384 --http localhost:8080 --static-map /static/style=/Users/aloraine/galaxy/static/style/blue --static-map /static=/Users/aloraine/galaxy/static --die-on-term --hook-master-start 'unix_signal:2 gracefully_kill_them_all' --hook-master-start 'unix_signal:15 gracefully_kill_them_all' --enable-threads --py-call-osafterfork 
Traceback (most recent call last):
  File ".venv/bin/uwsgi", line 6, in <module>
    from uwsgi import run
ImportError: dlopen(/Users/aloraine/galaxy/.venv/lib/python2.7/site-packages/uwsgi.so, 2): Library not loaded: /usr/local/opt/pcre/lib/libpcre.1.dylib
  Referenced from: /Users/aloraine/galaxy/.venv/lib/python2.7/site-packages/uwsgi.so
  Reason: image not found

The python I am running in my virtual environment (called “galaxy”):

(galaxy) $ python
Python 2.7.10 (default, Oct 6 2017, 22:29:07)
[GCC 4.2.1 Compatible Apple LLVM 9.0.0 (clang-900.0.31)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

I used pip to install wsgi in my environment, and it seems to have worked:

(galaxy) $ pip install uwsgi
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: uwsgi in /Users/aloraine/.virtualenvs/galaxy/lib/python2.7/site-packages (2.0.18)

Tips on what to do next would be great!

Many thanks,

Ann Loraine

1 Like

The most current Galaxy release can always be found here:

Example step-by-step for a basic local Galaxy install with an admin account created

  1. Go to home directory using Terminal on MAC OSX


  1. Set up a place to keep the local galaxy. I often need to do testing with fresh checkouts, so tend to use the version as the dir name. Wherever you put/name this, avoid nesting the location too much, or the path will get long and possibly present with Conda errors later on (it doesn’t play well with longer paths).

$ mkdir 1901

$ cd 1901

  1. Clone Galaxy

$ git clone -b release_19.01 https://github.com/galaxyproject/galaxy.git

  1. Let that run to completion ^^. Then go into the galaxy dir.

$ cd galaxy

  1. Set up the virtualenv

$ virtualenv -p /usr/bin/python .venv

  1. Initial startup of Galaxy

$ sh run.sh

  1. Then that runs using all default settings, ending with the server hosted at the local URL. Will then create my “admin” account in that web browser (but it won’t be admin yet!).

  2. After that will shut it down, change the galaxy.yml to become admin, start it up again, and log into my account in the web browser to make sure that I set up the admin config correctly.

  3. More can be done after that to customize your instance.

  4. I hope this works for you, too :slight_smile:

You probably know where these resources are, but for others reading:

In particular, have a look at:

Thank you!

It is working for me now.

1 Like

Update going forward:

For step 3, the release to get will update over time. Check here for the most current Git “Clone” command. And for help about how to upgrade an existing local to a new release. 19.05 is the latest now.

What is new in each release is in here, and also includes “upgrade” help:

Which means that this:

Will as of now be:

And that will change over time.

Thank you so much.
When i used your simple installation outline and ran sh run.sh on my terminal in my my Macbook, it all worked and a lot of packages were installed and it took about 12 minutes.
However, instead of giving the correct web url, it gave all this at the end including a kill signal, all shown below

Executing: .venv/bin/uwsgi --module ‘galaxy.webapps.galaxy.buildapp:uwsgi_app()’ --virtualenv /Users/emmanueldonbraye/galaxy/.venv --static-safe /Users/emmanueldonbraye/galaxy/client/src/assets --pythonpath lib --threads 4 --buffer-size 16384 --http localhost:8080 --static-map /static=/Users/emmanueldonbraye/galaxy/static --static-map /favicon.ico=/Users/emmanueldonbraye/galaxy/static/favicon.ico --die-on-term --hook-master-start ‘unix_signal:2 gracefully_kill_them_all’ --hook-master-start ‘unix_signal:15 gracefully_kill_them_all’ --enable-threads --umask 027 --py-call-osafterfork
Traceback (most recent call last):
File “.venv/bin/uwsgi”, line 5, in
from pyuwsgi import run
ImportError: dlopen(/Users/emmanueldonbraye/galaxy/.venv/lib/python3.8/site-packages/pyuwsgi.cpython-38-darwin.so, 2): Symbol not found: _Py_GetArgcArgv
Referenced from: /Users/emmanueldonbraye/galaxy/.venv/lib/python3.8/site-packages/pyuwsgi.cpython-38-darwin.so
Expected in: flat namespace
in /Users/emmanueldonbraye/galaxy/.venv/lib/python3.8/site-packages/pyuwsgi.cpython-38-darwin.so
emmanueldonbraye@Dr-Donbraye-MacBook-Pro galaxy %

How do i fix this so that galaxy will run on my system? Thanks
I am running python 3 on Mac OS 11.2.2 (Big Sur)