fgsea returns an error

Tried to run fgsea on a data set of ranked genes (symbols in column 1, log2FC in column 2) but it didn’t work. Same sets do run on the usegalaxy.org server.

Hi @Henk

To directly compare: click on the job details view for both jobs and examine the inputs, parameters, and tool version. I’m wondering if that might explain the differences.

Now, if those still look the same, you can post back the content from each and we can try to confirm the problem. Maybe we can get whatever is going wrong fixed. :slight_smile:

Thanks in advance for the followup! If you are able to solve this yourself, that would be good to know too!

Both data sets are of tabular type and the tool versions also seems the same.

Non-working .eu version

Working .org version




1 Like

Agree – those appear to be the same inputs and tool version.

Would you be able to post back the contents of the Standard Error from the failed EU job? Maybe also any text printed inside the red error dataset. You can capture both from that same view. I’m curious what the problem is.

Or, maybe better (would allow more troubleshooting) generate a shared history link to where the error is.

After that, I would suggest a rerun at the EU server just to see if the root issue was some temporary problem, but you don’t need to wait for that to complete.

I made the history shared. You can access it via the following link:


Curious to see what went wrong.


1 Like

Thanks for sharing the history, @Henk

All I did was import the history, queue up a rerun of the last failure, and toggle a single option (output Rdata). The job worked!

Shared here so you can see it: Galaxy

After you look at it or import it, let me know and I’ll purge my copy.

No idea what changed server side, but the situation seems to be cleared up now, whatever it was! It was probably some configuration issue if I am understanding the error log correctly. The EU admins likely found and fixed.