FTP Connecting Using FileZilla 530 Error

Hi I am trying to connect to galaxy using FileZille
I follow all the instructions on https://galaxyproject.org/ftp-upload/ but I still get the error 530 Login incorrect. I am sure that I am putting the right password in and I have tried access from three different accounts. I have also tried using the passive option
Host: usegalaxy.org
Username: awezm
Password: ********

The error I get is:

Status: Disconnected from server
Status: Resolving address of usegalaxy.org
Status: Connecting to 129.114.60.56:21…
Status: Connection established, waiting for welcome message…
Status: Initializing TLS…
Status: Verifying certificate…
Status: TLS connection established.
Command: USER awezm
Response: 331 Password required for awezm
Command: PASS ********
Response: 530 Login incorrect.
Error: Critical error: Could not connect to server
1 Like

Hi,

The “username” in Filezilla should be entered as your registered Galaxy account email address.

This is shown in the screenshots/help but can be confusing. The “username” in Filezilla is not your “user name” in Galaxy.

The similar labels between the two applications are unfortunate. What we can do is try to make FTP usage clearer around this in the help link you shared – I’ll make sure that gets done.

Side note: Everyone should be using only one account per public Galaxy server. This includes Galaxy Main https://usegalaxy.org. Duplicated accounts are picked up and deleted periodically by an automated process, without notice, resulting in access denial and data loss. For you or anyone else reading who wants or needs to proactively avoid this from occurring, consolidate your data into a single account and write us an email at galaxy-bugs@lists.galaxyproject.org and we can help you get down to one account, in effect protecting your access and data.

Terms and Conditions, item 2

Notice during account registration:

Hi,

Thank you for your response. I have also tried using the email address that was registered and I got the same error.

1 Like

Are you able to log into Galaxy at https://usegalaxy.org using the same credentials?

Emails are case sensitive, so double check that the case is the same between both methods.

Yes, and I made sure I am using the correct emails

The service is up.

Is the error when you use the email address the same or different? An error of Response: 530 Login incorrect. means that the server/credentials are not the same between the Filezilla entry and the Galaxy server where you are registered/logging into the application.

There are many public Galaxy servers - if the same exact email/password is used with both Filezilla and Galaxy, and you can log into the Galaxy server directly, a mismatched URL is the only other entry point that could trigger this error.

I am using localhost to connect to galaxy and it is still not working with FileZilla. Is there a different hostname I need to use to connect? I can get to the point where it says connected but waiting for welcome message and then it connects after 20 seconds of inactivity.

Are you trying to load data to the public server Galaxy Main https://usegalaxy.org or somewhere else? If Main, the “Host” can be either one of these, depending on your connection type (implicit or explicit FTPS). Details in the FAQ. When using Filezilla with the default passive settings, the first is used.

usegalaxy.org
ftps://usegalaxy.org

If trying to load data into your own local Galaxy with FTP, the configuration/process is different. The same FTP FAQ above has a link to the administrator help pages.

If you want to share screenshot to help describe what exactly is going wrong, that might be a good idea. You can edit out/redact emails/passwords.

Hi,
I’ve been having the same issue, either by connecting through Filezilla of lftp (Login failed: 530 Login incorrect).
Through lftp I am able to connect with email/password lftp:~> but when I put files I get the 530 error.
I was wondering how did you solve it?

1 Like

Hi @sofiamurga

Accounts are distinct between most public Galaxy servers. The location where FTP Uploaded data is staged is server and account specific. My guess is that your account is at a different public Galaxy server than where you are attempting to connect.

Check the URL of the server you are working at. Is it really usegalaxy.org?

If not, then open the Upload tool to check if the server supports FTP at all. If it does, the URL connection is usually noted in the pop-up. Please see the screenshot below.

Thanks!

FAQs:

1 Like

Hi!
thank you, your guess was right. The URL I´m trying to connect to is galaxy.docker.org (I´m trying to use Galaxy /Hutlab)
I still have not achieved it, is it the same procedure or am I missing something?

1 Like

Hi @sofiamurga

The public Galaxy server http://huttenhower.sph.harvard.edu/galaxy/ has its own dedicated forum (for all tools/servers associated with the lab.

Try contacting the server admins at this forum: https://forum.biobakery.org/. I do not see any posts about the correct FTP URL and the URL included in the Upload tool is not specific enough (it appears to be a default URL). They may not actually support FTP Upload. But ask them for clarification.

The contact information in the Galaxy Directory for this server is also outdated. Their forum is somewhat new – and I’ll add to the directory page. (https://galaxyproject.org/use/huttenhower-lab/)

Hope that helps and please feel free to link back your Q&A at the other site to this post if you want to. I’m curious as well about the status and URL for FTP Upload at that site.