Help! A weird error about hyperparameter selection in tutorial workflow

The error, parameter ‘sp_name’: an invalid option (‘selectkbest__k’) was selected (valid options: memory,Note:,Parameter,steps), occurred in the workflow “Age prediction from RNASeq (from training material)” which was imported from the published workflow repository in Galaxy Europe. The other two hyperparameters, “elasticnet__normalize” and “elasticnet__alpha” in this step also met similar errors.

To solve this problem, I tried to create a new workflow according to the tutorial in by the latest version of tools. However, it still does not work. This error is weird and I hope for some help very much. Thanks a lot! :pray: :pray:

Hi @t-harden,
thank you for the report; could you have a look @anuprulez? I can confirm that there’s a problem in the current training.


Hi @t-harden,

Can you try to use the latest tool version (the latest version on Galaxy Europe of search cv, hyperparameter optimization tools is: Galaxy Version in the workflow you are using? Everything else remains the same as explained in the age prediction tutorial. There was an issue with the previous version and we fixed it a couple of weeks ago. Let us know if you face further issues.



Thank you very much @anuprulez @gallardoalba , when I switch the version of tools from to, the error I mentioned above do not happen again and the correct results of Step 3: Hyperparameter Search return successfully. :v:t3: :+1:t3: